Installing HP printer on Ubuntu 22.10

I am attempting to install my (home) local network printer. Ubuntu displays it has found my local printer.
I then click to “Add” and select from the Network Printer options

Click “Forward” and this window displays

Click “Apply” and I get a CUPS server error

I went to the HP web site for drivers and was instructed to another site because of Linux OS. I proceeded and downloaded to my Download folder the indicated driver.

What am I doing wrong?


I have yet to hook up a printer … so no true experiences … did you search to see if others have been where you are now …

I read where HP printers were good in Linux … it might be a “sharing” problem …

wait … here comes the :grinning: … help you need

If it found it, there should be no need to add it again. simply unlock the Settings window, right click, set as default and then right click again, select properties and locate print test page. It should work if Ubuntu found it. from there if it does not works.
Open a terminal run sudo apt update && sudo apt list --upgradable
sudo apt upgrade -y
Allow the updates, log out of session or reboot and try the test page again.

1 Like

Thanks MrDeplorableUSA - luv your name!

Update…tried each step as suggested. ‘set as default’, selected properties and when I did the
‘Print test page’ was highlighted however, nothing printed.

I then went to the second set of instructions, restarted my laptop, revisited ‘Properties’ though now not highlighted.

one thing about “network” printers that most annoying is they change IP addresses.
Suggest going through the actual physical printer settings. write down the current IP and MAC address and add it to your router as a static IP for that MAC address. Unlock settings and then point the printer to that IP address.

Thanks! Will give it a try.



1 Like

Hi Mr.D…USA,

I’m finally able to try out your suggestion. 2 items; 1) I have seen or needed to “unlock” the Printers dialogue box, am I missing something? 2) In the Printer window below, where do I insert the IP Address and Mac Address for my printer?

Can you get the screenshot of the previous screen or whole screen prior to printer settings? This looks like Ubuntu/Gnome DE.
Should look like a “lock” in upper right I believe.

Following our earlier exchange, I tried using the CUPS web interface to install the printer. Seems like it was ready to work however, as before, “Unable to locate printer…”


Is this indeed “Gnome”? When you first open Settings > Print Settings, before selecting anything, check the top of the Settings box for what anything related to a lock/unlock.

Also can you output “groups” via a terminal to list your users groups.

You could check under here since it is a network attached printer:

I can only get the hp printer to work using hp-setup. It works with hplip.


Thanks again for your guidance. Please see my response below to chuck on the outcome

1 Like

Hi chuck,

Thanks so much for your help. Your guidance along with downloading the software from HP (sudo apt install -y hplip-gui), made it happen. Can’t tell you how excited I am to achieve this.


1 Like

Glad you have it working,
Fortunately I have never had to use any manufacturers programs: Epson, HP, Lexmark or Cannons that I have had in the last 10 years.
Ubuntu was by far the easiest to get any of my printers running on but can say, Debian has been pretty much a breeze there as well.