Installation - Can’t Boot From USB

Trying to boot from USB. Tried UEFI Boot Order USB Flash Drive/USB Hard Disk. Keeps blowing past it and going straight to Windows. Any ideas how I can force it to boot from the USB?

Assuming the bootable USB is inserted when you select these options, that tells me that you need to select something different.

For me, when I boot to my USB, the boot loader lists it as “SAMSUNG FIT DRIVE 1100.” Look for something like that. It is also possible that it could come up with some derivation the name of the Linux OS you’re attempting to install.

If you don’t see anything like that, you might have the wrong format, there may have been an error while writing the iso to the USB, or your system may be locked down. In which case you would need to look into unlocking it.

Typing F11 at the startup gets me here…

F9 Gets me Here…

This is where I am stuck. If I pick “Boot From EFI File”. It tries to read the install disk and I am not sure what to pick to run. I used this same disk to install linux on two laptops earlier this week. Not sure why this is not working on this new HP Pavilon Computer - Model TP01-1227c

Once you have your USB thumb drive plugged in (provided you flashed it with Balena Etcher or Rufus), it will appear on the boot list (F9).

What options come up after you select “Boot From EFI File”?

I was having same issues trying to load Ubuntu from the USB and even though i had the correct order in BIOS, it was not following orders and booting into windows. I figured out I had to use FAT32 to format instead of NTFS inside the Rufus settings.

1 Like

Ah yes, FAT32 is the format that should be used for sure.

Thank you friends, all of the info presented below has got me to a new place…

Summary… Got the problems solved with not being able to boot to USB.

I created a new usb stick with Balena Etcher as recommended. Have a new problem. which I will check to see if someone has posted, then if not will post a new thread.

1 Like

I was having the same problem. When I went into bios settings [F2 for me] and changed the boot order it still didn’t work.

Then I discovered that if I hit ESC instead of F2 it would take me to a different pre-boot window.

This window was strictly for selecting a device to boot from. I selected my USB drive and voila - problem solved!