iMac boots to black screen

Hi, I had trouble putting linux mint on a 2010 iMac , the iMac would not see the usb drive when I put the software on it using the terminal, but after I used Belena-etcher to put linux mint on the pen drive it went through the complete install and told me to reboot.I reboot and it starts to load but then it goes to a black screen as though it has shut down, but after a few seconds I can hear the chime indicating it has completed the boot up. Does anybody have an idea what I can do to get the screen to show the program? I am using a mid 2010 iMac and installed Linux Mint.
Thanks, Rich

Hi, I just want to add to the information above that I can get linux mint to load and run from the usb drive. The problem doesn’t happen until I install and try to boot up from the hard drive. I hope someone has some ideas.
Thanks again, Rich

I suspect that Mint may not have the correct graphics driver for your system. Boot into Mac OS and then, via the Apple menu, click on “About this Mac”. That should tell you which graphics card your Mac is using. If not, then click on “System Report” in the dialog box that shows you your system configuration and you will see a more detailed list of hardware on your system. Post screen shots of both those screens.

Perhaps Vaselios can then walk you through installing the driver manually into your Mint distribution (if that’s possible to do) so that it may show up when you boot. That part is beyond my abilities at the moment. :slight_smile:

Thanks @Midline, I can’t boot into the Mac OS because I have Mint installed, and for some reason it will not let me boot into recovery mode so I can get into the system report. I did make a pdf file of some of the system report before I installed Linux Mint though. Here are a couple of pictures I think you are wanting.
Screenshot from 2022-02-01 07-51-56

@rlegarra are you still having this issue? I noticed it had been a while with no reply. Please let @vasileios know that you still need assistance. Cheers!

Hey Rich, AKA @rlegarra!
Thank you @BigDaveAZ for tagging me on this one! I believe this just went through my radar undetected.

Linux Mint uses an older Kernel which may not include everything you need, or it could be encountering kernel errors which are not visible when you first boot. I haven’t personally tried it on a system like yours, but I was able to install Zorin Lite to a 2008 and a 2009 iMac successfully.

When you first start up, try to hit the ESC button or the Shift button until you come up with the Boot Menu (text based). Then select the Advanced Options to enter a secondary menu. From that point, select the “fallback” or “recovery” option (usually the 2nd one will do). This should take you to a menu where you navigate with your arrow keys. Make sure you are connected to the Internet (preferrably via an Ethernet cable connected to your router) and select to activate the network. Once that is done, it will return you to the menu. Select to drop down to root terminal and press CTRL+D (if memory serves me well) to enter it as root.

From there on, execute:

apt update && apt upgrade -y

If the network works correctly, your system will undergo a full upgrade, which will hopefully set the correct parameters for your system and bring all dependencies up to date.

Please let me know how that goes.

Hi, @vasileios and thank you for responding. I did try Zorin Lite and several other distros but couldn’t get the computer to see them. I can get the computer to run on Linux Mint and it runs great I just need to plug in an external monitor long enough to get the computer monitor to start displaying. I tried to get to the Boot Menu you suggested but can only get to a Boot Menu with an installation usb disk in the machine, which only gives me the option to boot to the disk or the hard drive which will boot up but with a black screen. Is there a way to do the full upgrade with the computer booted into Linux Mint? I did try to use the update and upgrade commands using sudo as well as switching to root neither of which fixed the problem.

Hey @rlegarra!
Apologies for my delay. New LMS courses take their toll.

I’m suspecting it’s a configuration in the boot sector of Linux that gives you a headache. If you’re able to boot into Mint normally, open up a terminal and execute the following:

sudo nano /etc/default/grub

Navigate with the arrows to the following line that reads:


And add the nomodeset option, so that it looks like:

GRUB_CMDLINE_LINUX_DEFAULT= “quiet splash nomodeset”

Press CTRL+O then Enter to save. Then, CTRL+X to exit.
Once back in terminal, execute:

sudo update-grub

And try a reboot to see if that helps. :slight_smile:

@vasileios, you are the man. No apologies necessary I understand how busy you must be trying to keep up with all of us linux beginners. I am in the LMS class and have put linux on 5 computers, 2 iMacs, 1 Macbook Pro, 1 Dell Desktop and 1 Dell Laptop, and just 2 days ago I got my Open VPN going on Linode. I didn’t know anything about Linux when I started a few months ago but try to gain a little knowledge every day. This change to the grub command line solved the problem, the iMac computer is now booting up without connecting to a tv. It is now telling me my video driver may need updating but when I run the driver updater it tells me that all my drivers are up to date, got any ideas on that? Thanks again for the great advice on the monitor booting problem I have been working on it for a couple weeks and was about to give up and just keep a tv close by.

1 Like

I’m glad to hear you no longer need the TV, Rich! :slight_smile:
Per the driver, your Mint could be confused and running on software drivers at the moment. Can you install Inxi via:

sudo apt install inxi

And then send me the output of its command below?

inxi --full

This will give me an overview of your system, the graphics hardware, and the driver being used. :slight_smile:

@vasileios, here is a screenshot of the command output

Thank you, @rlegarra!
The driver loaded appears to be correct. I believe that the error you’re getting is because Cinnamon (the Desktop Environment) is running on Software Rendering mode. You can check the Compositor settings and see if it allows you to switch it back to OpenGL. I don’t have Mint installed on my current system, but I remember it being there.

Please let me know if that helps!

Hi @vasileios, at the login screen I had the option of using cinnamon (default) or cinnamon (software rendering) I selected the cinnamon (default) and it brought up the message that I needed to update the driver, so I rebooted and logged in using the cinnamon (software rendering) choice and when it booted up the request to update the driver didn’t come up. I’m thinking the problem might be solved but I will play around with it a while to see for sure. Thanks again for the help.


1 Like