Illegal filename in syncthing

I installed Syncthing several months ago and although it worked fairly well I don’t use it anymore. When I do updates and upgrades I always get this error message " Ignoring file ‘syncthing.lis’ in directory ‘/etc/apt/sources.list.d/’ as it has an invalid filename extension". I have unininstalled and auto purged yet the invalid file exists. When I access the file’s properties it shows that I don’t have rights to the file. How do I get rid of this fille?
I’ve done some digging and have not found this issue.

Which flavor of Linux are you using? And what general hardware specs?

Do you have a file named syncthing.lis in /etc/apt/sources.list.d/

Simply remove the file since you have purged the application.

Apt will read the files in sources.list.d/ after contacting the sources, typical distro related, listed in /etc/apt/sources.list

sudo rm /etc/apt/sources.list.d/syncthing.lis

Perform your updates as normal and check again.

1 Like

Thank you Mr. D!
That worked.

1 Like