How to mount drives in Ubuntu

I have a bit of an issue here. I made the switch from Windows to Ubuntu (Zorin 16 actually, but built on 20.04). The switch has been marvelous with one small hiccup. I have 3 drives in my system:

128gb NVME SSD
256gb NVME SSD
2tb Hybrid SATA HDD

When I was running Windows, I used the 128gb SSD as my boot drive, the 256gb as my gaming drive (where I had installed my couple of games I play and a few files/programs that I wanted fast connection to) and finally the 2tb drive for just bulk storage for things that didn’t need to be accessed ‘fast’ on an SSD. This worked pretty well on Windows, however, I haven’t been unable to replicate it on Linux. I am fairly confident it is possible, but I’m hardly a Linux guru (…YET! still learning).

The story doesn’t end here though. I have my system successfully running on the 128gb SSD. That is where my Zorin install is and all is good.

The other two get messy. I can go into my file manager and access the files on my 2tb Hybrid HDD, but I have to manually mount it every time I want to browse it or move files on/off of it. Not the end of the world, but I would prefer it to be persistently mounted, even through reboots.

The 265gb drive is not accessible at all on the system. I cannot mount it any way that I have found yet. That being said, it does show up in the hardware listings of the system in terminal. See below:

phillip@Zorin-Order66:~$ sudo parted -l
Model: ATA ST2000LX001-1RG1 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 134MB 134MB Microsoft reserved partition msftres
2 135MB 2000GB 2000GB ntfs Basic data partition msftdata

Model: BPX (nvme)
Disk /dev/nvme0n1: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 538MB 537MB fat32 EFI System Partition boot, esp
2 538MB 120GB 119GB ext4

Model: ADATA SX6000NP (nvme)
Disk /dev/nvme1n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 1066kB 1049kB LDM metadata partition
2 1066kB 134MB 133MB Microsoft reserved partition msftres
3 134MB 256GB 256GB LDM data partition

phillip@Zorin-Order66:~$ lsblk
loop0 7:0 0 4K 1 loop /snap/bare/5
loop1 7:1 0 55.5M 1 loop /snap/core18/2253
loop2 7:2 0 55.5M 1 loop /snap/core18/2246
loop3 7:3 0 219M 1 loop /snap/gnome-3-34-1804/72
loop4 7:4 0 164.8M 1 loop /snap/gnome-3-28-1804/161
loop5 7:5 0 105.8M 1 loop /snap/mailspring/506
loop6 7:6 0 42.2M 1 loop /snap/snapd/14066
loop7 7:7 0 43.3M 1 loop /snap/snapd/14295
loop8 7:8 0 219M 1 loop /snap/gnome-3-34-1804/77
loop9 7:9 0 347M 1 loop /snap/wine-platform-runtime/277
loop10 7:10 0 346.9M 1 loop /snap/wine-platform-runtime/278
loop11 7:11 0 383.4M 1 loop /snap/wine-platform-6-staging/46
loop12 7:12 0 65.2M 1 loop /snap/gtk-common-themes/1519
loop13 7:13 0 383.1M 1 loop /snap/wine-platform-6-staging/44
sda 8:0 0 1.8T 0 disk
├─sda1 8:1 0 128M 0 part
└─sda2 8:2 0 1.8T 0 part
nvme0n1 259:0 0 111.8G 0 disk
├─nvme0n1p1 259:1 0 512M 0 part /boot/efi
└─nvme0n1p2 259:2 0 111.3G 0 part /
nvme1n1 259:3 0 238.5G 0 disk
├─nvme1n1p1 259:4 0 1M 0 part
├─nvme1n1p2 259:5 0 127M 0 part
└─nvme1n1p3 259:6 0 238.4G 0 part

So the system sees the hardware, but I’m not sure what I’m doing wrong or what I need to do to fix the issue. Both the 2tb and the 256gb drives are NTFS filesystem format. I do have access to the 2tb drive and can move things on/off of it if it needs to be reformatted/start over, however I do not have access to the 256gb drive. I’m not opposed to blowing the data on the 256gb drive away if that is what is needed and there are no other reasonable methods of recovery, however, I would like to review its contents before doing so.

Sorry for the lengthy opener, hope this provides a somewhat clear picture, and thank you to anyone and everyone in advance for any suggestions!

Hey @delta26!
The process is simple. Follow the instructions of the two screenshots I made for you. The app I’m using is “Disks” (AKA Gnome Disks).

In your scenario, the drives will appear as NTFS and not as EXT4 that you see on my pictures. :slight_smile:

Thanks @vasileios but this only worked for the 2tb drive (actually the 2tb drive was already setup like this in Disks which I think is why I could access it in my file manager). The 256gb drive actually shows the ‘Edit Mount Options’ button greyed out. Below is screenshots:

I also noticed this in the df output:

phillip@Zorin-Order66:~$ df
df: /run/user/1000/doc: Operation not permitted
Filesystem 1K-blocks Used Available Use% Mounted on
udev 8108928 0 8108928 0% /dev
tmpfs 1632712 1996 1630716 1% /run
/dev/nvme0n1p2 114337956 84306184 24180636 78% /
tmpfs 8163544 0 8163544 0% /dev/shm
tmpfs 5120 0 5120 0% /run/lock
tmpfs 8163544 0 8163544 0% /sys/fs/cgroup
/dev/loop1 56832 56832 0 100% /snap/core18/2253
/dev/loop0 128 128 0 100% /snap/bare/5
/dev/loop3 224256 224256 0 100% /snap/gnome-3-34-1804/72
/dev/loop2 56832 56832 0 100% /snap/core18/2246
/dev/loop4 168832 168832 0 100% /snap/gnome-3-28-1804/161
/dev/loop5 108288 108288 0 100% /snap/mailspring/506
/dev/nvme0n1p1 523248 5356 517892 2% /boot/efi
/dev/loop6 43264 43264 0 100% /snap/snapd/14066
/dev/loop7 44416 44416 0 100% /snap/snapd/14295
/dev/loop8 224256 224256 0 100% /snap/gnome-3-34-1804/77
/dev/loop9 355328 355328 0 100% /snap/wine-platform-runtime/277
/dev/loop10 355328 355328 0 100% /snap/wine-platform-runtime/278
/dev/loop11 392704 392704 0 100% /snap/wine-platform-6-staging/46
/dev/loop12 66816 66816 0 100% /snap/gtk-common-themes/1519
/dev/loop13 392320 392320 0 100% /snap/wine-platform-6-staging/44
tmpfs 1632708 104 1632604 1% /run/user/1000

For some reason, df shows the 256gb drive being mounted at /boot/efi and that its 2% used?? I found that pretty odd. Not sure if this is something I maybe messed up, or if I need to maybe check/change something in BIOS?

Ideally, I’d like to have this 256gb drive permanently/persistently mounted and able to have linux programs installed on it. Thanks again for the help!

Ah, it seems to have a different type of formatting. It’s the LDM (Logical Disk Management), which is similar to Linux’s LVM (Logical Volume Management). The process to mount those is different. First, you will need the tool-set that will allow you to mount it:

sudo apt install ldmtool

Once installed, execute the following command to see which partition it is (as well as the drive’s ID).


Locate the UID of the /dev/nvme1n1p3 and copy its UID. Then, you can mount it with:

ldmtool create volume <uuid> <volume-name>

Paste the UID in the uuid (no brackets) and choose a name for the volume-name and it will mount for you.

I hope this helps!

DUDE!! You da man!! I got it working, thank you so much!!

1 Like

You’re most welcome, @delta26!