How to mount an encrypted SSD

I have an SSD from a laptop that suddenly went read-only. It is encrypted and the operating system is Pop OS. Laptop won’t boot.

I would like to see if I can get this drive mounted on another machine. Also running Pop OS, and also with its own encrypted drive.

When I plug in the drive it prompts for a password, but the drive isn’t mounted – more specifically, the cryptdata partition won’t mount.

Don’t know much about LUKS. Tried these commands:

sudo cryptsetup luksOpen /dev/sdb3 cryptdata
sudo lvscan
sudo vgchange -ay

The first command results in “Device cryptdata already exists”. I think this is because the machine I’m trying this on has an encrypted drive as well. If I use a name other name cryptdata, I get a message “cannot use device /dev/sdb3 which is in use (already mapped or mounted)”. From the Disks app, /dev/sdb3 shows that it is already unlocked – I assume because it prompts for a password when plugging in the drive.

The lvscan issues a warning about duplicate VG names, showing one inactive and one active /dev/data/root. Also /dev/mapper/data-root already exists (using df command).

In /dev/mapper there is is cryptdata, data-root, and a luks (plus UID). I’m thinking the luks-* device is the unlocked /dev/sdb3 – but I’m not sure how to address the lvscan/duplicate VG names.

lsblk looks like this:

NAME                                       MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                                          8:0    0 931.5G  0 disk  
└─sda1                                       8:1    0 931.5G  0 part  
sdb                                          8:16   0 931.5G  0 disk  
├─sdb1                                       8:17   0   512M  0 part  
├─sdb2                                       8:18   0     4G  0 part  
├─sdb3                                       8:19   0   923G  0 part  
│ └─luks-d6e5251e-7a53-4446-ab24-1b267da3bf42
│                                          253:2    0   923G  0 crypt 
└─sdb4                                       8:20   0     4G  0 part  
nvme0n1                                    259:0    0 931.5G  0 disk  
├─nvme0n1p1                                259:1    0   487M  0 part  /boot/efi
├─nvme0n1p2                                259:2    0   3.8G  0 part  /recovery
└─nvme0n1p3                                259:3    0 927.2G  0 part  
  └─cryptdata                              253:0    0 927.2G  0 crypt 
    └─data-root                            253:1    0 927.2G  0 lvm   /

I’ve since tried a bunch of stuff that I can’t remember. Whenever the drive does appear in Nautilus, I click on it and after a few seconds, get a dialog box that says "operation cancelled.

It may be that the drive is just busted. But if anyone has some suggestions, I would like to see if I can get it mounted, even if read only.

Gives this a read and see if it helps.
How to Mount LUKS Encrypted Drive Partition in Linux