How to get KDE Connect (Manjaro) to work with my VPN? (OpenVPN on Linode)

I’m just getting set up with Manjaro KDE Plasma and would like to try KDE Connect. When I tried to pair my laptop to my phone, it would not pair. So I disconnected my VPN, and boom, it paired quickly. So I would like to know how to get KDE Connect to work with my VPN. I read it has to do with bridging, which I know nothing about. Thanks for any help! :slight_smile:

Can you connect your phone to your VPN? I have that on my list of things to do, connect other devices/machines to my openVPN but have not tried it yet. I did have my tablet connected via wireguard before I uninstalled it and went to openVPN, so I know multiple devices are doable.

1 Like

Hi Macks, Yes, both my phone and my laptop are connected to the VPN that I set-up myself on a Linode VPS using OpenVPN. I have a deGoogled Pixel with Graphene. I had to get the “OpenVPN for Android” app to connect to it on my phone.
My problem is that when my devices are connected to the VPN, they won’t connect to each other with KDE Connect.

Hey @LibertyMom!
The process can be a bit complicated if we are to take on the tech side, so I will avoid it for now, as we wouldn’t want to hinder the VPN function.
A way you can try is to go to your VPN connection under the Network Connections and under the IPv4 tab, select “Method” as “Shared with other Computers”. Once that is on, disconnect your VPN (if it’s already connected) and re-connect. Then check if you can see the other systems via the network inside your home.

1 Like

Hey Vasileios! Thanks for your suggestion. I changed the IPv4 method and restarted it but unfortunately my phone and laptop still won’t pair while the VPN is up.

IP communication, in general, requires that each device know the IP address of the other device. If both devices have the same IP address it would certainly confuse them. although I don know the specifics of how the phone and desktop are configured to know where the other is, I wonder if they could be set to same IP address but different ports.

1 Like

It would appear that we’ll need to go via the more technical approach.

@MacksM3, my hope was that this option would engage a “sharing” option which would open the system to the Local Acess Network (LAN).

@LibertyMom - first, you’ll need to determine your internet gateway’s IP and the subnet mask. In order to do that, you will need to run the following command while disconnected from the VPN:

route -n

If the command is not available, you can install it via:

sudo apt install net-tools

For example, this can output something along the lines of:


In my scenario above, the gateway is 192.168.1.1 and the Subnet Mask is 255.255.255.0

This can be verified via the ifconfig command:


Note: NetMask = Subnet Mask.

Jot down those two IP addresses (Gateway and Subnet Mask). Normally, the Subnet Mask tends to be 255.255.255.0.
The Gateway network is the IP address of the Gateway itself, with the last digit being 0. Therefore, the entire network that goes through a 192.168.1.1 Gateway is 192.168.1.0.

Next, you’ll need to open up a terminal and SSH to your VPS that runs your VPN (again, with the VPN deactivated). Once you login, execute the following:

sudo nano /etc/openvpn/server.conf

You will notice that your VPN Server’s Network & Subnet are:

server 10.8.0.0 255.255.255.0

At the end of the file, add the following lines:

push "route X.X.X.X 255.255.255.0"
client-to-client

Where X.X.X.X is the Network of your Gateway (for example, if it’s 192.168.1.1, the X.X.X.X should be 192.168.1.0 - if it’s 10.0.0.1, then the X.X.X.X should be 10.0.0.0, etc.)

Then press CTRL+O and then Enter to save. Then CTRL+X to exit.

Once back in the terminal, execute:

sudo systemctl restart openvpn.service

Then disconnect from the SSH and connect to your VPN on both devices and give it a shot.

Please note that I haven’t personally tried this - as I don’t have my KDE connected to any phone. However, it does allow me to access the LAN while connected to VPN.

1 Like

Hey Vasileios, thank you for your very detailed ‘assignment.’ lol
I followed all your instructions to a T. However, the KDE Connect still doesn’t work when the VPN is up.
The main thing I want to be able to do is send photos or files back and forth between my Manjaro KDE Plasma laptop, Budgie Desktop, Mint laptop, and my Graphene phone, while the VPN is up on both. Is there another way to do this?

Hey @LibertyMom!
VPNs sometimes tend to act in a… moronic way, even though the settings behind them are valid. In our live workshop today, I wanted to display file management on the network (Local Access Network). I was connected to the VPN on the host system via NordVPN, which had the settings to allow LAN access. However, it could not connect to any of the nearby systems. I tested it on another system I had nearby, also on NordVPN and it connected normally to the network filesystems.

If you simply want to transfer files and photos, the best way is to connect your phone via a USB cable. That’s the approach I personally use, and it’s a heck of a lot faster!

2 Likes

Well that’s a simple solution!
Someone in Telegram mentioned SFTP. Would that be a good idea if I want to do it wirelessly?

Also, several months ago I mentioned creating a bootable USB drive so that I can run Linux on my Macbook Pro and have persistence - like an external hard drive. You told me I needed 2 USB’s, one with a distro flashed on it, and the other a large capacity USB. I have both of them now and would like to proceed with getting this set up. When are you available?

Hey @LibertyMom!
SFTP or Secure FTP is an entirely different setup, which will require you to set up your device as an FTP server. Even if you do so, there is no assurance that you can see it when you have both devices on VPN. Additionally, an FTP account will engage a specific directory structure outside the folders you are looking to copy. A good example is the FTP server we set up on the LMS. It can see the public HTML area for the website, the email files, and the WordPress installation - but it cannot see what is stored within the Linux OS (and the home folder area).

I generally use the USB solution, which works very easy for my android phone (I used to utilize) and the iPhone I have.

First, please remind me of the year of your MacBook Pro. Today is Sunday, so I try to dedicate some time to my family - though this is proving to be a divine challenge!

I was looking at some nice guides to get you going on this regard. I found a “preppy” guy who posted a video on that, but his solution was less than half-baked. No mention of the T2 chip, no mention of the possibility of a different boot-loader, nor the necessary steps to allow booting from an external drive (not just a USB). He was more like “yeah, just press option and everything will work at boot.” Uhm… nope! :laughing:

Anyhow, I believe the following article will get you prepared:

You can ignore the first part where he burns the Ubuntu ISO as an IMG file. Etcher can do that for you.

Also, if your system doesn’t boot into the USB, you might want to restart your MacBook Pro, hold down CMD+R to boot into the recovery area, then go to the “Security” Menu part and check to see if the screen that pops up has any restrictions on booting from an external drive. If yes, then disable it.

If the steps in the article help, then great! If not, we might need to configure a different boot-loader. I hope it won’t come to that. :slight_smile:

1 Like

Thanks Vasileios, you absolutely should be spending time with your family today! Thank you for the article. I will read it to get ready. Here is the thread where we discussed this back in October. No Sound on 2016 Macbook Pro with Ubuntu - #32 by vasileios
My computer is a 2016 Macbook 13,1. From what I remember 2016 MBP’s are troublesome for installing Linux, although I don’t remember why.

Thank you so much @LibertyMom!
There is a way to install Linux on nearly all MacBook Pros (with the 2018+ though being extra stubborn due to the T2 security chip) via the rEFInd boot loader.

Have you been able to boot Linux on your 2016 MacBook Pro via USB?

1 Like

Hey Vasileios,
I have but I had problems with the keyboard, track pad and audio.

The thing is I don’t want to completely convert my Macbook Pro. At least not now - I need it still as it will take me probably a year to completely convert everything. That’s why I was thinking my solution would be to boot with a bootable USB with Linux.

1 Like

I did a USB install of Garuda Linux with my macbook, I can power down, remove the thumbdrive and it runs the mac OS again. This install does not want to connect my apple magic mouse and keyboard however, and I am thinking I may need to install it on the internal HDD to get that working. I had Manjaro installed on the internal HDD for a while and was able to easily connect the magic mouse, but had display driver issues and ended up restoring the mac OS with time machine.

Hey @LibertyMom!
Since you were able to boot, then you may be able to bypass the issues. However, you’ll need a USB keyboard and mouse to go through the process (and of course, Internet, where an ethernet cable will come in handy, and perhaps a USB-to-Ethernet adapter, which works out of the box on Linux).

Once you have those, then you can install Linux in the external drive, but make sure that the Grub (boot loader) is installed on that external drive. So, when you want to boot into Linux, you’ll need to hit the Option key and select your drive, while you can still boot into your macOS without having to press anything.

For the hardware that is not functional, you can follow the guide in the link below, going to the areas you need (and bypass the installation). The guy installs Linux as a dual-boot system on the main macOS drive, so you don’t need that - as you have your external one.