Help! Got a new computer and nothing will install

I got an ipower gaming PC and it will not boot anything. I’ve tried everything I can think of. I’m trying to install Mint, and when it gets to the partitioning part, all that shows up is the USB. In Bios, I can see my all my drives are there, but when I try to install anything Linux or Windows, it does not work. It was originally a windows computer, then I installed Ubuntu. I could not get the sound to work, so I tried to install Mint instead, and I really messed something up. Any suggestions before I return the darn thing? Thanks!


I can offer you some things to try but first lets make sure we know what your return policy is. Would the store where you purchased it from take it back as an open box and not being able to boot at all? What is the cut off date for your return? I just want to make sure you take the best course of action if you are running out your deadline.

Just curious, can you still boot to Linux using the USB stick?


Hi Michael. I have about 10 days to return it, I got it from Best Buy, well someone got it for me. I can get Linux on USB but it will not download. I have tried to re-install windows but it says there are no drivers, when I try to install Linux, it doesn’t see anything but the USB drive. I would prefer to install Linux, but I’ll take windows just to get it started, then try to re-install. Thanks.


Please help me understand that when you say “I can get Linux on USB but it will not download”, I’m not exactly sure what you mean.

In order to install Linux on any computer you first need to create a Linux Boot-able Installation Media.

You do this by downloading the proper .iso file from the Ubuntu web site. Then you need to flash that .iso file onto the USB by using a program like ‘rufus’ to make it boot-able. There should be nothing more to “download”. If this is not the case, will you have access to another computer that has internet connectivity to create it and try again? Here is a step by step guide with pictures and options

When you say re-install windows, are you just tying to select windows from the boot menu when you power up the computer or do you have a windows installation DVD?

Ok, I have other computers to made the boot-able USB, I have one with Linux Mint that will not install once I get to that point. I also have a Windows recovery USB but when I pick the option to boot from that, the computer does not find the drivers, so the install fails. I have the USB’s, but outside of the Bios menu, it seems like there is nowhere to install to, neither my SSD drive or HDD drives are showing, just the USB.
I previously had windows and Ubuntu, so they show up as selections on the boot menu, but neither will boot. On Linux I get the initramfs shell, and the no driver on windows.

Thats what I get with the USB connected.


Thank you for the screenshots and you have confirmed for me that you do have a proper Mint install USB as I see it boots to that so you can then select the install icon.

It appears to me something is not quite right with the disks or the disk controller.

When you boot to the Mint USB session can you open up a terminal

Ctrl + Alt + T

Then maximize the window and then type

inxi -Fxz

There will be a long output of your system specifications. Please share with me the section named Drives: , Partition: (and RAID: if present)


Ahh, thanks for this screenshot and I believe the motherboard has your SATA disks set up s RAID and not AHCI in your BIOS. This is what is probably causing your installer to not properly read and write to the drives because there needs to be a driver for this and I bet its only for windows.

So, lets just pause here and see if you still want to continue or do a return. Is it possible to check with Best Buy that if we change these settings you are still ok to return if you want?

RAID can be configured to speed up the R/W performance of disks as well as for data redundancy for disk drive failures. It appears it has been set up on this system and is a feature of this model for gaming. I’m not an avid gamer so the impact of RAID vs. Non-RAID I do not know, so if we continue we will probably have to remove this functionality. Linux runs better and more efficiently than windows on a desktop anyway so to me its no big deal, but I just want you to make a proper decision moving forward.

If you are OK to continue, Boot to your BIOS menu and look for the menu that sets your SATA ports and see if you can change it from RAID to AHCI. Save those changes and then try to install Mint once again.

1 Like

OK. Do I leave the SATA Controller Enabled or Disable it? Then I changed the SATA mode selection to AHCI.

Hello @KatM!
Again, thank you @mva for your help!

@KatM, while in BIOS, make sure that Secure Boot is disabled and that the keys next to it are cleared out. Then you should have no issue installing Ubuntu, Mint or Zorin (which I personally enjoy). :slight_smile:
Please let us know how it goes.

1 Like

Yea, I had Secure Boot Off, Its installing now, located my 1T hard drive, finally!! I can’t believe it was so simple!! And I have Zorin on my other desktop, it’s one of my favorites, and Fedora on my laptop which I like too. Thank you guys so much for all of your help!!

1 Like

Thank you so much, Michael! It is installing. Your the BEST!

1 Like


Thank you for the kind words and I’m very happy we were able to help you jump over this hurdle. Most of the thanks goes to Jeff and @vasileios or starting this great movement!