Having trouble setting up linux mint for graphene os install on pixel 3xl, need to download the image now, pixel is "not found"

Hi, I’m trying to switch my new pixel 3xl to graphene os using my linux mint machine, following the instructions on their website. I have enabled the bootloader unlock and debugging, am in dev mode, but my machine isn’t recognizing the pixel. I installed the dev tools via the software mgmt, and later tried to add them via terminal after adding myself to the dev group, but was denied access. I am not sure at what point to connect my device, trying a few times at probably the wrong moment. I need some advice please!! I’m not giving up on getting this done, and will be doing others after I get this down. I do have a windows pc but don’t want to use it unless it’s needed, and a manjaro machine. :slight_smile:

Hi, Elizabeth! I hope I can help you with this. I install grapheneos using my linux mint machine with Brave as my browser. If your browser and OS are up to date, you’ll also need to make sure the android sdk platform tools are installed. Once all three of these are done, it should be “go time” with no problems. To install the android sdk platform tools:

  1. open up a terminal
  2. type: sudo apt-get update -y
    3: type: sudo apt-get install -y android-sdk-platform-tools-common
  3. Check the system logs to confirm there are no errors

My first time around, I had the same problems. Once I made sure everything was up to date, it worked like a charm. As far as connecting your device, once you’ve done the preliminary work (enabling oem unlocking and booting into the bootloader interface, you are ready to connect and go. I’m not sure if this will solve your problem, but I hope it helps. If you have further questions, feel free to ask. There are several more qualified people than myself on here…so perhaps they will chime in too if further help is needed. God bless!

1 Like

Thank you Teresa, I followed your instructions. I got the bootloader unlocked, but now the pixel wants to start up and set up. I tried to download the graphene image, but it says no compatible device found, although to unlock it the pixel was found, so I don’t know what to do next. This is frustrating for me. The bootloader is now unlocked, and I think next is download the image, but am not finding how to do that as the pixel is “not found” any more… arrrggghhhh! lol.

Can I ask what browser and OS you are using?

I had similar problems, but then I switched to a fresh install of Linux mint cinnamon and Brave.

1 Like

Brave on Linux Mint with KDE.

There’s an admin on Jeff’s channel that helped my mother with questions about KDE. I’m reaching out to him for you or can forward his information to you. Perhaps he can help. This is an issue I haven’t faced in any of my installs yet…though I’ve had my fair share to overcome! I’m proud of you and everyone who is making this leap!

Hi Teresa,

Sorry it’s been a little while. I put that on the back burner and made a few changes. I’ll be using Manjaro KDE Plasma instead of Mint, and I do use Brave… plus I switched to ethernet, and am studying the info before I get back to this! I get a lot of help on the Tech Garage channel so I do think it will work. I got the bootloader unlocked, so I’ll be following the instructions closely!! Thank you for all your help!!


Bones’ Tech Garage is definitely my “go to” for all things degoogled! I’m glad you’re over there as well! Now that the bootloader is unlocked, it should be smooth sailing!