GRUB won't go

I posted a question 9 days ago and had no reply so I have taken out my HDD and formatted it. I am totally confused now because when I try to enter set-up f2, f12 the GRUB comes up. I have nothing on the HDD, it’s formatted. How do I get past this GRUB so I can install the OS?

Excellent question Ray. I apologize for the lack of response. I am no hardware guy at all. Let me see if I can find someone to help. I want to encourage your trek towards cutting the ties that bind us to Big Tech.


@vasileios @admin

1 Like

If you haven’t installed a Linux distro on the hard drive, you need to boot up a USB stick with a distro and run it live, then have the USB install the distro on your drive. When the install is finished, click Restart, and then remove the USB drive when told to do so, and your pc should reboot with a new grub installed for you.

Thank you, but what I am trying to achieve is updating my bios. I was trying to do it with ubuntu but it wold not do it because ubuntu at boot up says there is a bios problem (bug) and cannot read a symbol. I thought I would install windows and update the bios with that and then install ubuntu. When I have the windows in to install on my formatted drive I am getting the ubuntu grub and I can’t proceed bast that. At the point of selecting at the grub my keyboard stops working. I have tried another keyboard but it s the same.

OK. Sorry that misunderstood your situation. Updating the bios is something I’ve heard about but have never done. I’d do a search for “how to update bios software”, without the quotes. If you’re using Windows, you’ll find instructions on how to do that. You’ll likely need to go to your pc manufacturer’s website and download the bios update from them.

Thanks. I do know how to up-date the BIOS but the system is not letting me do it…

Hey @Ray!
I apologize for missing it. At times I check the posts and something else arises that demands my immediate attention - and then forget about it - as the posts go away from my feed.
Updating the BIOS will depend on the BIOS itself. Does it have an option to read the update file on its own or does it come only with a Windows-based flash utility?

In the former option, you can copy the file into a USB and load it from there from inside your BIOS.

It is a windows exe file… I cant get past the GRUB asking me to try or install when the there should be nothing there… My keyboard locks except for esc

In that case, it will need to be run directly from Windows, as it will need direct hardware access to your mainboard’s firmware.

I am trying to install windows but this GRUB wont go away

I figured if I install Win10 to update the bios then reinstall ubuntu, it will run again without a problem

1 Like

Since you have an exe file for the firmware, then yes. That’s what I did for an older HP laptop I had to update its firmware for. In another case, where the BIOS flash was done from the BIOS itself, I just downloaded the file from the website, placed it in a USB (directly from Linux) and then loaded it directly in the BIOS setup.

In your case, a temporary Win10 installation is - unfortunately - needed.

Yes, so how do I get past the ubuntu grub screen when all keyboards I use seem to be disabled? I am so frustrated by this…

In order to install any OS, you don’t need to bypass Grub. You’ll need to enter BIOS or at least the Boot Menu (in some systems it’s the Escape button, while in others it’s the F12) so that you redirect it to boot from the USB that holds your bootable OS installation.

If you tried several keyboards without success, have you attempted to use a different port? Because if none are working, it could be a port issue.

Not a port issue… The keyboards work fine until I go to install. F12 just takes me to the grub … As I keep saying, I can’t get past the grub because the keyboard some how is disabled at this point… This is why I removed the HDD to format it. I have no keyboard function to install anything…
If I install Win on the HDD using another computer then put it back in the target computer to update the bios, would this work…???

I would recommend you install the HD to another computer. Then remove all partitions (as from what you’re describing, one is still there) and then create one partition to include the entire drive and format it. This will get rid of Grub completely. From there on, you can install via USB the OS you need.

OK thank you. I thought I had formatted the whole disk but I will check it and do it again.

1 Like

It is just one partition as far as I see.

Which somehow still contains Grub (and is FAT32). I’d recommend still formatting it fully to make sure that the boot sector is cleared up.

The system you have that 750GB HD is a single-drive one, correct?

Yes 750GB HD…
I did it again and got this…

error: no such partition.
Entering rescue mode…
grub rescue> _

My screenshot wouldn’t upload but that’s the screen message.