Frustration with Cursor

For the zillionth time, I just wrote a paragraph of text and had it suddenly get selected and deleted. I believe the issue is that Linux instantiates activities on the basis of cursor position. I cannot express the level to which I despise this.

I DO NOT WANT ANYTHING TO DO ANYTHING UNLESS I TELL IT TO.

When my cursor happens to be at the new tab position of a browser, I do not want it to make a new tab because of this. I can very easily exercise the click button. When my cursor is outside of any application and sitting on a blank part of the screen, I do not want it to somehow and suddenly open up a search bar and have my text suddenly type in this suddenly opened up search bar. If I want a search bar, I’ll get it myself, thank you.

I get so exasperated, I swear I am going to take a shotgun and blow my computer with Linux to smithereens.

So, I have a question.

Is there any way to configure things so that NOTHING is instantiated on the basis of cursor position alone?

Can you provide a bit more detail? Are you using a text editor and seeing your text disappear when, for example, opening another application or similar? If using a text editor, which one?

1 Like

Tanks for responding, Narcosis.

It happens on virtually every application, including this forum and libreOffice, though I sometimes use libreOffice Writer because if any text gets selected and deleted, at least I can undo. (Then I’ll paste the text to where I want it.) Could it be my laptop? It’s a Dell Latitude 7480.

As far as detail, text getting selected and deleted. Actions instantiated, such as if I happen to have the cursor at the + button of Brave, and having a new tab get created. This is why I left Zorin and went with Linux Mint. I think it happens less with it but not sure.

But I have to believe there is something in Linux that “tells” the cursor to take actions on the basis of its position alone. Am I wrong on this?

Never once happened in Mac OS and though it has been many years, I do not believe in Windows either.

Shooting from the hip here, are you using a laptop with both a trackpad and external mouse? I had to disable the trackpad when my external mouse was connected ( 2013 macbook air ) due to my hands coming into contact with the trackpad & making a mess of what I was doing.

2 Likes

The cursor position issues you are running in to are not because of “linux,” which has existed free from “cursor problems” for at least twenty years.

You are experiencing improperly configured “focus-follows-mouse” settings, where window focus changes according to the cursor position.

You may also be experiencing problems with “Mouse Hover” settings.

You should disable these and you will be back to standard mouse settings, which are normal in Linux.

Not sure why Focus Follows Mouse," or “Mouse Hover” were enabled on your computer, but they are not enabled by default.

If you’re using a laptop, the touchpad might be too sensitive and interpreting taps as clicks.

Adjusting the touchpad sensitivity or disabling tap-to-click might help.

Remember in Linux, if the desktop environment you are using isn’t 100% to your liking, you can always switch to do different desktop environment that gives you more granular control over window focus and mouse behavior.

Ambiguously blaming “Linux”, (insinuating that the entire OS is somehow ‘defective’–it is not) won’t solve the problem for you. Learning how to better control system settings will.

1 Like

I am almost always not using a mouse.

Well this is a relief.

With what you are saying, I am guessing it is “mouse hover” settings. I have never heard of such a thing.

I will try to find out how to change such a setting. I presently have no idea.

Finally, of course I was unaware of ambiguity!

Outstanding! Glad you found a solution… :slight_smile:

1 Like