Forgot my password

I recently took the initiative to leave big tech after events of the past couple years.

I bought a Dell XPS 13 2021 Developer Edition with Linux Ubuntu this past January.

Linux has been much more difficult to use than I expected. I haven’t used my computer in a while, and now I’ve forgotten my password, and cannot reset it. I feel like I threw money down the toilet!

I’m writing in the hopes that someone may be able to help. All the online forums I’ve researched do not give me the correct indications to reset my password. When I reboot my computer holding down the ESC button, I get a GNU GRUB version 2.04 menu, which is different to what is displayed in all the forums regarding forgotten passwords. (see the photo of my screen). Holding down the shift button doesn’t do anything on my computer.

Where do I go from here? Any help would be greatly appreciated! Thank you!

Have you looked at this page?

2 Likes

Hey @chamas and welcome to the forums!
Yes, when you hold down the ESC key, it drops you into the Grub console. You only need to tap the button once.

The moment you get the Grub Menu, you can then go to the Advanced Options and hit Enter. Select one of the Recovery options and it will bring you to a window with a variety of options that you can navigate with your arrow keys and select with the Enter key.

Select the Drop to root terminal and hit Enter. Once in terminal, execute:

passwd $(ls /home)

This will read the folder within the Home directory and pull your username. Then, it will ask you to input a new password, twice. Once done, execute:

reboot

And you’ll be good to go!

2 Likes

Thank you so much @vasileios !! Finally THE perfect answer I couldn’t find anywhere else. It worked perfectly, and I’m very grateful for your help. :pray:

Good morning Vasileios, just like Chamas, I did what I thought was the easier route by purchasing, coincidentally, the same computer as Chamas, a Dell XPS 13 2021 Developer Edition with Linux Ubuntu already installed. So far I absolutely love it. I am still pretty clueless, but have managed to get my printer etc added with no issues. I signed up for the beginners course a couple of weeks ago and will make my way through it in hopes of becoming more self sufficient.

My issue: I left the country for the summer and when I returned I could not remember my log in password, can’t find where I wrote it down etc. Thankfully, I did set up the fingerprint when initially setting it up so I am able to access my computer, but as you know, without the password there are limits as to what you can do.

I followed the simple instructions via youtube as well as yours above to reset my password and in both cases, I always end up back at the purple “log in home screen”.

This is what I am doing: I go to the drop down, hit power off then click on “restart” and as soon as I do this I tap the esc key, I have done both tapping it as well as holding it down and the end result is the same, cycling back to the purple home screen. It does flash to a black screen with all of the (I have no idea what it is, code??) and at the end reverts back to the home screen. I have also tried this by tapping and holding down both the esc and shift keys, not at the same time.

Your instructions seem so simple, but clearly I am doing something wrong. I cannot get into the Grub console in order to access the Grub menu and follow the balance of your instructions.

I am hoping you’re able to help???

Many thanks in advance,
Billy

try this shutdown.
wait a few secs and hit the power button, tap the ESC key a few times as it powers on, you should be greeted with a menu then that lists Ubuntu and a few others below it, then this is where you would proceed to follow vas’ instructions on resetting the password.
I think your just hitting ESC to soon after pressing the reboot as it needs more then a few secs to shutdown its current session, cycle the laptops and begin its warm boot.

Thanks for the speedy response. I have tried multiple times and still have no success. When I let it shut down completely and wait a bit before starting it back up and then tap esc a few times, I am now seeing in the upper right corner “F12 Boot Options”, this appears to be un-clickable and I have also tried clicking the physical fn and F12 buttons simultaneously, thinking that may take me to where the menu I need is.

Following your instructions I am seeing this:

  1. F12 Boot Options upper right corner
  2. then it goes to a black screen with all of the computer
    speak, this is only briefly
  3. then it goes to the purple home screen

Should I try videoing this so someone can see what I am actually doing although, I think I am describing it accurately?

OK, SUCCESS!!! I still have no idea what I was doing wrong, but I kept playing with it and finally ended up somewhere that looked right, I went to “drop to root shell prompt” and then followed the prompts.

I was able to reset and then reboot and logged in with my updated and “saved” new password.

This community is amazing and I can’t thank you enough. I am super stoked!!

Have a great Sunday!!

Billy

1 Like

You’re quite welcome, but that was all @vasileios , I just try to break it down a lil bit to help whenever I can.

1 Like