Error on Creating Bootable USB for GalliumOS

I’m getting an error in creating my bootable USB from the correct GalliuimOS hardware version (Bay Trail). The .iso file passed checksum and is correct, but when I write it to USB (tried 2 different flash drives) using my Mint Cinnamon laptop …
“Unable to mount GALLIUMOS. Error mounting /dev/sdb3 atg /media/(mycomputer)/GALLIUMOS: wrong fs type, bad option, bad superblock on /dev/sdb3, missing codepage or helper program, or other error.”
I’m 2 months into Linux, so a near-total-newbie, but having tried about 20 distros on various laptops so far, I feel like I shouldn’t be getting tripped up by this error at this stage in prepping for GalliumOS for a Chromebook. It may be an easy fix, but I’m stumped. Any ideas? Thanks so much!

Hey @Sandra and welcome to the forums!
Which operating system are you using to flash the ISO to the USB?

Hi Vasileios! I’m using Linux Mint Cinnamon on a Dell laptop. I’ve tried both the USB Image Writer and downloaded Balena Etcher. I’ve tried different flash drives (16 GB) in both USB ports with no difference. It appears to complete and passes validation, but then gives me the error as shown. I was thinking I’d also give it a try on my old Windows desktop. Thanks!

Update: It appears to have worked from my old Windows 7 Professional desktop; however, I did plug the flash drive in to my Linux Mint laptop and I see the same error. I’m confounded! :smiley: Could it simply be that the Mint laptop doesn’t want to recognize the GalliumOS flash drive?

The Chromebook is due in Friday and I suppose I’ll try it as is … the Windows computer (using Etcher and validated) did not show any problems. If I still have issues with the USB boot/install not working, I’ll holler back. Any other suggestions? Thanks so much for your help! This Granny is loving learning something new!

Hi Sandra. I had issues with Gallium OS also. I ended up installing Manjaro on my Dell Chromebook 11 instead. Everything works, all of the other distros I tried I was unable to get sound from the built in speakers. I loaded Manjaro, and after my first update, everything works. Let me know if you get Gallium to work though, Id still like to try it.

My bad! I should have noticed you have a Chromebook. This is what happens when I do run around a bit too much! My apologies.
Chromebooks are a challenge to shift to Linux - as some may require a firmware flash. We have two admins on the Telegram channel who have been at it, but I haven’t heard from them in some time regarding their project (they had a “contest” as to who would get their Chromebook up first).
Shifting this specific laptop will require a bit more technical skills.

First, it has to do with the CPU. Is it Intel-based or ARM based?

My personal opinion - if your Chromebook is still due today, would be to exchange it for a laptop that is Intel (or AMD) based, so that you have less challenges to face.

Hi @vasileios and @KatM !! I DID IT. The Chromebook arrived at 9:30 and here I am at 2:40 with a “new” computer! I did my research and basically lucked out (plus I can be stubborn and won’t give up). Here are the problems I had and the fixes in case it helps anyone else:
*I had issues making a bootable USB flash drive GalliumOS on my laptop that runs Mint. Fix: I was able to get it done by using Balena Etcher on my old Windows desktop.
*You have to remove the Write/Protect screw from the board; there are videos on YouTube on doing this, but for some reason while flashing the firmware from, I still had WP in red, meaning WP was still enabled. Fix: On looking at the board again, I saw a little of the 4-part copper circle had a little copper kind of “smushed” over to touch the next portion of the circle, so I ran my fingernail down the “alleys” separating the copper sections to be sure the connection was broken. Somehow, the little piece of metal touching its neighboring section kept WP enabled. Trying it again, this was fixed; WP had switched to green and I was able to flash the firmware.
*GalliumOS installation copied all the files, but the installation process had an error and would not complete. Fix: I found where others had noted they needed to be OFF WiFi (and even unplug the charger) to install the OS. Disconnecting from WiFi and pulling out the charger cord allowed the installer to complete. After rebooting (without the USB plugged in) into GalliumOS, I reconnected the WiFi and ran the GalliumOS Updater. After this, I could install Firefox (sudo apt install firefox) and went to to get “back in the game” with you all over on TG. I’ve tried downloading the Linux version from, but I’m running into a problem where it thinks it’s still for Chrome, but it’s not. The web version will work just fine at this point.

The YouTube person I watched also suggested running GParted before running the installation. Running off the USB, GParted is an option; just type it in to the Search field and it comes right up. I deleted EVERYTHING that was still on the Chromebook so I had a full, clean installation.

I surely am still a newbie, but I was fortunate enough to find a way to do this in time to give to my veteran son who is home for Christmas. I hope these notes might be helpful to someone!

1 Like

Congratulations!! Good to know about the Wi-Fi thing for installing Gallium, if I decide to try it again. Does your sound work properly? That was the biggest issue I had with other distros on my chromebook. Since Manjaro is working pretty good right now I’ll probably stick with it. But it sounds like you did an awesome job and found the fixes yourself! Way to go! My next challenges are a used tablet that I’m getting next week, and I have my older Samsung phone on the way from Moms in NC, those should be fun.

1 Like

Thanks!! Yes, the sound seems to work fine; I tried some song samples and they played as I’d expect. Also, the touchscreen still works, too. Nothing so far that has been a problem once working through the issues above. Very grateful for solvable issues! Good Luck on the tablet and phone; I’m betting they’ll go just great!

1 Like

Hey @Sandra!
That is awesome and congratulations! You may consider yourself a newbie, but you definitely have problem-solving skills and a technical affinity! Bravo!

Thanks, @vasileios ! I so appreciate it! My 90-year-old Dad has seen this one for my son (who was thrilled) and wants one, so I’ll find a couple more on eBay and get to work. I need one, too! Plus … I was reading where the same GalliumOS Chromebook can be used as a home server with a 128 or 256 GB flash drive ….

I think you guys have created a Monster!! :grin::rofl: I’m so, so happy to be doing this and I thank you all so much!

1 Like

The only thing we did was awaken a problem-solver in you! So, this is all you here!
And you are most welcome! :slight_smile: