Error installing several distros. Unable to find medium containing a live file system

Not sure how or why I am not getting this when I try to install several different distros on another one of my computers. " Unable to find a medium containing a live file system" error message after the initial boot up from the USB stick. I have each distro on separate USB sticks and have successfully install all of them on other systems. Can anyone give me their 5 cents worth ( inflation, increased interest rates) as to what I may have done wrong.

Thanks in advance


1 Like

Hardware description? Now it could also be as simple as a dirty USB port or nasty broken port tab


Hey @Pernicieus and welcome to the forums!
@MrDeplorableUSA makes a good point. At times, the image was not written correctly by the app (or the protocol that the app used), and in other scenarios, it’s a simple USB misbehavior. Worst-case scenario, the USB port is drunk with the way it passes the data. I’ve encountered many occurrences of each scenario. In the case of a software issue, you can utilize a different app to flash your drive.

In the hardware part, a minor power fluctuation on the USB port during recording can mess up the entire process - hence producing a faulty image.

I’d recommend retrying the recording from a different USB port, to begin with. If that doesn’t work, try a different USB. If that doesn’t work, change the recording app. Which application did you use to flash the thumb drives?

1 Like

Thanks for the replies.

USB stick all brand new
Etcher program to load ISO
Computer trying to image Motherboard is 10 years old and have had issues with the usb ports in the past. I tried another port on the motherboard and not the frontside USB. I even reimaged the USB sticks with an undated ISO and same issue.
I think the issue is the motherboard/USB ports as even the WINDOWS media creation USB I have used in the past and recently also reimaged didnt work.

I will update once I have updated the hardware.

What other suggestions for creating bootable USB images other then ETCHER?

Thank for all the comments and assist. I sometimes get focused on one path that has worked in the past and forget other potential issues that could be causing my issue.



1 Like

There are a few out there, not sure what your on, but I’m leaning more towards hardware issues.

If this is a Desktop/PC and you have continued to have this issue, I’m guessing this hardware related and you need to poke around inside. If this is a laptop, and your up to it, the same procedure can be followed BUT I would locate a SxS breakdown of your model and do NOT forget to unplug the battery.

Shutdown and unplug. Open the case and trace your USB wires, make sure their connected solidly and the coating is not rubbed off on any sort of metal and been grounding, pinched, kinked or severed in anyway shape or form. If you suspect those fine wired are damaged in anyway, replace them.

Take a flashlight and magnifying glass and visually inspect the USB ports, if they look corroded you can use a toothpick and contact cleaner(put contact cleaner ON the toothpick, please do NOT spray it in to your USB port LOL) You’d be surprised. If the port looks “dirty” at the back use the toothpick to scrape loose and then a can of compressed air to clean it out(Do NOT USE a compressor air line, oil in the air will cuase issues, use ONLY clean compressed can of air). You will have to use something skinnier for other side of USB port opposite the contacts. A descent sewing needle should work.

Let us know how it goes.

1 Like

Update on my issue. I too believe it was hardware related. I have replaced the motherboard and no more issues. and I have successfully loaded KDE 5.24 Plasma/Kubuntu.


Bravo on solving it @Pernicieus!
@MrDeplorableUSA, this was solid advice. Sometimes, however, the issues of power fluctuations are not visible to the naked eye. I had something similar happen to my SONY Vaio years back. Due to humidity, the computer started zapping me at some point when I’d touch metal. I had a good look at it, but it all looked squeaky clean. A while later, its graphics chip got fried.

1 Like

Desktops are especially finicky. There are many loose wires, I’ve literally built hundreds over the years. Just because there is not a damaged USB cable, never means nothing’s wrong, a CD/DVD/HDD wire grounding can cause many issues, including zapping you. Best bet is to “loom” your wires. Wire loom is available at most major auto parts stores and will give great added protection on loose wires. There may well have been nothing wrong with your MB.

Something a roll of electrical tape for a $1 and a long lasting, reusable roll of loom for $6 could have fixed.

1 Like

LOL tell me about it! My current setup looks nice on the front, but when you view the back side of the desk, there’s so much spaghetti-like cables that would entrance pasta-lovers! :laughing: