Elementary OS- error updating software, error trying to load software

Hello! I have an old ASUS that I installed Elementary OS onto a few months ago. I have been trying to update the software and system, but keep getting an error within the software updates page, as well as in the terminal. I have also tried to install “tweaks” for Elementary and am receiving the same error in the terminal:
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
I have tried running sudo apt udpate several times, sudo apt upgrade, and have tried the command apt --fix broken install to no avail. Not coming up with any other solutions when I search for a fix online. Any help greatly appreciated!

I would first assume that with “apt --fix-broken install” you used the sudo command as well?

Have you perused the log viewer(usually under system tools) for “dpkg.log” or “dpkg.log1” for a description of unmet dependencies?

Thank you for the reply! I tried it both ways-with and without the “sudo” part just to cover my bases. I’m unsure where to go to see “unmet dependencies” :woman_shrugging:t2:

I know the link refers to askubuntu but being a deb based distro it should be able to help with the issues.

You can try fixing the broken dependencies using the following command:

sudo apt-get -f install

sudo dpkg --configure -a

Then run this again:

sudo apt-get -f install

You can find in details how to fix the dependency error in this thread.

I hope this helps resolve your issue.

Ok, I just ran those commands, did not hit any obvious issues or get error messages. But when I go back to software to update the software I’m still getting an error that says it failed and “This may have been caused by external or manually compiled software”. The only updates left to go are operating system related. ie: Operating system update; Online accounts settings; User account settings; and several others. 15 total. Yesterday I was able to update some others in the list individually. But these 15 just have not budged.

Actually there is an error (didn’t have my glasses):
E: Sub-process /use/bin/dpkg returned an error code (1)

since granite seems to be a Elementary companion library you may need to reinstall midori-granite to fix its libraries.

Give this page on stackexchange a look.
Stackexchange Midori-Granite ElementaryOS.

I’ll give that a shot- thank you so much!