Drive share and backup program

I have a total of 10 machines on the network all windows 10.
I am starting the with my file server have installed Linus Mint 20.2 on fresh HD (pulled the win 10 drive to set aside). First task is to get the file folder shares out for my windows (and later linux) clients to be able to use as primary data store.
File server data drives were and are still NTFS formatted. Had a heck of a time getting to share these as read write and found out that Win10 locks NTFS unless you disable fastboot in windows, did that and got share working for these NTFS drive folders.
I grabbed samba, allowed through FW, added user to samba share group, added samba PW to the user. Then I go to Linux file explorer and go to the drive and folder and right click and share, Allow others to create and delete…

ISSUE: All works until I reboot Linux then the shares go away and I have to repeat the share from the Linux file share again. Is there some software I should be using for this persistent sharing or do I NEED to be updating the samba.conf file?
Next step will be to replace Cobain Backup that I had on my win 10 box. I have an external drive and a WD Mycloud on the network that I want to be targets for my backups. I want them to run daily on a schedule and mirror the primary drive, meaning if I delete a source file or directory I want that deleted on the target.
Question: After research I am thinking that I may try Luckybackup for this but in software manager reviews I see that dev has stopped since 2018. Do you have recommendations for software that will perform this backup (scheduled) and with targets being either external drives and/or network shares?
Follow up to the above is that my next win to linux change will be another machine that is only used to backup (additional backup that is) the file server. So the backup software for this machine will be backing up source (shared folders from file server) to local target (again previously NTFS formatted) drives.

Hello @cesande !
Did you happen to check the response from the support email? I sent it earlier today and I apologize for the delay. I believe I address your concerns there.

Unless you wish for a second opinion. :wink:

Very sorry I missed the reply.
Will respond there if I have any issues.
Much appreciated

1 Like

No worries. I took me a bit longer to respond. :slight_smile:
However, if you do need anything, please feel free to take the discussion to this thread.

Thanks much for the reply and working through it.
Today I have found a new issue perhaps after updating all packages.
My 3 drives, 2 NTFS (1 internal and 1 external USB) and 1 EXT4 (internal for time machine backups) now don’t auto mount after a reboot.
I have to click each of them in file manager and enter password to mount.
This auto mount ‘was’ working until just today.
Thoughts on this one?
Additionally I have shares that I have to connect and mount on my WD Cloud used as internal net NAS.
Basically what I am trying to accomplish is have all drives auto mounted at reboot, have Samba auto share folders to my other clients, and then get backups done from local File Server to local USB external drive and to WD drive.
Looking into freefilesync for this as it looks to do what I need AFTER I get auto mount and auto Samba share after reboot figured out

Hi guys -

i am looking for some min specs on what I could use as an email server/personal cloud. $$ are a major factor. is there a vid out there or someone who will literally walk me step by step - from unboxing to server SW (FOSS) to whatever the next step would be? I am fairly tech savvy but spoiled by the Mshaft and I am great at following clear directions. I am tired of BT.

Check my reply above when you have some time please.

It’s actually simple. All you have to do is run disks (gnome-disks, which is installed on Ubuntu and Mint - I believe). Once it opens, select your drive, go to the cog under the long bar that represents its partition space and select Edit mount options.

From there, you disable the automatic mount and select manually. Also, in the end of the last photo, where you see “Identify as,” you can select the disk to be displayed by its label (name).

I’m attaching the screenshots from my laptop (though it has only one drive, the process is exactly the same).

THANK YOU !!! I researched that earlier today and tried it and it didn’t work. Tried again now and drives are mounting at boot ! YAY another step down in the process.
Any tricks to get the Network WDMyCloud folders to mount on boot?
I ‘may’ not need that if freefilesync has an option to mount at time of running backup to WD as target.

Thanks again so much for your help!

Woops forgot to hit reply on the above message.

No worries! The least complex type I could find - since SAMBA is tricky, is via autofs.

Please have a look at the following link and let me know if it gets too complicated. It doesn’t matter if it’s Ubuntu. Mint is Ubuntu-based. :wink:

http://www.bernaerts-nicolas.fr/linux/74-ubuntu/56-ubuntu-autofs

WOW I am not sure how you did it but check this out!
Got the internal and USB drives to automount - but when I went to share I got the error that I needed to add to samba.conf usershare owner only = false
Using your suggestion for autofs got the WDMyCloud folders to auto mount.
Rebooted and lo and behold !!! the NTFS shares STUCK on reboot!
Reboot and forgot to log back in to Linux and launched file explorer in windows box and BAM shares are all there… YAY getting there thanks to your help!

Still looking at freefilesync (reading that it does mirror which I want and can schedule for daily backups) for backup of file server to USB drive and MyCloud but that may have to be a project for tomorrow.

VERY appreciative of your help and patience with me!

1 Like

Dangit! Did it again.
Wanted you to see the reply @vasileios

1 Like

Not to worry! It happens. :slight_smile:

And it’s my pleasure to be able to help!

Per your backup project, you can have a look at these free solutions.

If you want to go for any paid one, this one is worthwhile:
https://www.goodsync.com/

Have fun! :smiley: