Dell Latitude E5500 bios/ Ubuntu install

I am trying to install Ubuntu on the Dell Latitude E5500 but I have a problem. I am unable to boot from USB because it’s not in the options. I have tried to fix it by updating the bios but that too is not accessible. The system is asking for a password to unlock all the system adjustments and I don’t have one. I tried partitioning the HDD having Ubuntu on a small partition so I can install it from there but it is asking about root. Running Ubuntu from the drive without installing is fine. It’s an old laptop with 4G RAM, 2GHZ x 2 processors and 160GB drive. I have done all the tests and everything is OK…
Any suggestions how I can get this running please…???

Did you purchase this used or buy it new originally?

That can make things very difficult having a locked BIOS. quick searches on DELLS site:[en]

Might try replacing the hard drive with a new SSD … I had the same trouble with a old laptop I found in storage locker … could run a live session but would not allow the drive to be reformatted … after replacing the hard drive with a new (used) drive all went well …

1 Like

Hello Mr D,
thank you for your reply.
A friend owns it. He got it from a local market here. we are in Cape Verde and we always get reject things from USA and Europe, it’s a problem… There are never any new products here, everything is ‘refurbished’…
I will look at the ‘jumper’ option…
It confused me because it says that there is no pw set for either bios or hdd when I looked… It is frustrating that I can’t boot from usb and install.

Thank you Mr IB,
I was able to format the hdd without any problem, it’s the new system install that wont do it… I can’t boot from usb to do the install… Everything needs this strange pw…

I just realised the Jumper option is for a pc :frowning:
Is it possible to install Ubuntu 16.04.6 32 bit on the HDD using a 64 bit pc and then putting it in the 32 bit laptop…???

well, you would have to install the 32bit version on the 64bit PC, but since you say there is no BIOS or HDD passwd set and you have successfully formatted the hdd…

Can you send pics of the process?

Thats a hassle…lol I went down the rabbit hole on the Dell site and eventually I was redirected to Dell France because it was last registered there. I submitted a request for a password to reset everything, I am now waiting for their response. Their site in in French and going through Google translate would not allow the site to work properly so it was a guessing game in the end filling out the fields.


This may help you.
[[How to reset forgotten BIOS Password -Dell Series, Dell latitude series, All in one series - YouTube]

1 Like

you are a champion. :clap: :clap: :clap:
I had given up because Dell would not release the PW for “security reasons”… I couldn’t believe it when they said that. A laptop that’s 20+ years old and they give that excuse. They also required a receipt of purchase lol
I went to that site and entered the numbers and it worked first time…
Now I am trying to figure out how to actually update the BIOS because the part that allows me to update does not show up. I have loaded Ubuntu Mate on it and it’s fine. It could be better with the updated BIOS but it’s functioning well enough as is…
Thank you so much

Pleased to see you got it sorted.
I very much doubt a BIOS update would enhance your Ubuntu environment.
Most BIOS updates where beneficial for the Windows environment. But that is another story.
Anyway…Good luck on all your endeavours and all the best. :wink:

1 Like