Debian 12.4 installation fail on Dell OptiPlex 7040


I’ve run into an issue with a fresh install of Debian Bookworm to a new nvme m.2 ssd.

After 5-6 attempts to install Debian, the post install fails to boot. No grub errors.

I’ve tried re-installing Grub from LIVE DVD several different ways to no avail.

In the Bios set-up I’ve manually tried to set-up the new NVME but it after booting it resets the drive info from PCI(…) to VenHW(…) [VenHW appears to be a windows boot manager setting]

I now believe the BIOS/EFI is full or corrupted. There are 16 boot listings showing in efibootmgr.

Suspect #1
Initially the no-graphical expert install completed with a question to update NVRAM which I’d not seen before and accepted with YES.


Finally gave up Debian as it wants to be the primary install and doesn’t like my dual boot with Arch LTS.

Installed Garuda KDE-lite from a DVD.

The Garuda Soaring Installer took a LONG time with osprober-bios update. 3 passes timed out before finally succeeding. (I suspect that the BIOS was messed up somehow and Garuda corrected the issue.)

I started out with a dual boot Debian 12 / Arch LTS. (production / sandbox).

Now have a Garuda KDE Arch / Arch LTS (production / sandbox). Running happily after restoring /Home and the VirtManager /var/lib/libvirt/images.

Finally can get back to my CNIX virtual machine!