Current input timing not supported by monitor display

Everything was going fine, and then I tried to install Proton VPN on a Mint desktop. Somehow the display got totally messed up. So then I uninstalled ProtonVPN, but it was still messed up. I want to reinstall Mint to fix it and get back to where I was, but after I get to the ubuntu selection in the boot, I keep getting the message “Current input timing not supported by monitor display…” It tells me to change it to 1920x1080 or higher. I can’t do anything else but let it boot to the current messed-up Mint OS. When I go to the Display settings, there is nothing as high as 1920x1080, there are only two very low choices. Does anyone know how I can get around this? Previous install of Mint went perfectly fine!

Have you tried completely shutting down both the monitor and desktop computer? Complete power off then restart both.
If that doesn’t help and you want to reinstall you may need to hit the key combination for your computer to get to the boot menu to select your usb drive.

Hi @dennis thanks for your reply! Yes, I have shut down and then restarted everything. It is after getting to the boot menu and selecting the usb drive is when I get this message. I have done some research online, but most solutions (aside from making sure cables are secure) are for Windows machines.

If possible could you post a picture here of what you are seeing showing the message?
What are you using for a monitor? (manufacturer and model)

Here I get to the boot menu with my Mint ISO:

Then when I select ubuntu, I get this:

I was previously successful at loading Mint onto this machine with no problem.

Thank you, in your first picture, if you want to reinstall then you want to select the:
UEFI: Generic Flash Disk 8.0?
If you want to try to fix what you already have then we need monitor make and model info.

The message is a Dell message, you may need to go into the BIOS and look for display settings (I don’t know if there is such a thing in BIOS)
Adjust your monitor settings with the monitor controls built in to the monitor.

Edit: I guess maybe I should ask if the monitor is a Dell or if the computer is a Dell or may both are Dell.

They are both Dell. I looked around in the BIOS and could not see anything I thought would help there. I am unable to adjust the resolution with the monitor controls. The only place it seems I can adjust the resolution is in the System Settings / Display. And the only choices I have there are 1024 x 768 and 800 x 600. I have tried each of them, with the same resulting message.

@dennis I tried selecting the Generic Flash Disk and it worked! However, even after reinstalling Mint, my display is still messed up. I must have really done a number on it with that ProtonVPN! Not sure what to do now…

When you booted from the Generic Flash drive did the display look correct?
When you say reinstalled did you (re)format the drive during install or not? If not reformatted then it could be a GRUB (or something similar) setting that is messing with you.

When I reinstalled, the display did not look correct. I erased the disk and reinstalled Mint.

Then there is most likely something amiss with the monitor or computer or monitor cable.
What kind of video connections do your computer and monitor have? VGA, HDMI, Digital HD?
Is it possible to try a different monitor?

It is a VGA connection. The confusing part is why did it work before the Proton VPN installation? And why am I not able to get back to that with a clean install of Mint?

Ok, I think I fixed it. I read several random posts online and tried one that said to unplug all the connection and power cables from the monitor. Hold the monitor power button for 8 seconds and then release. Plug the cables back in. Surprisingly that worked! Thank you @dennis for your assistance!!!

I do not believe that Proton VPN had anything to do with the problem. If resetting the monitor fixed it that is very good. The manufacturers like to combine functions in a single button. That usually works well until someone stumbles on just the right combination of “things” that cause a malfunction of the single button model. Most likely you found an obscure bug in the Dell monitor.
A power failure at just the right time can initiate problems similar to what you experienced which brings to mind, always shut the computer down from the desktop menu button. A hard reset with the power button can cause funny stuff to happen also.

Thank you…that is all good information for someone like me, who is trying to be a techie. It’s strange that the fix I used worked, when resetting to factory reset using the monitor controls did not…I don’t think technology always makes sense, which is frustrating. Now, do I dare try to install Proton VPN again?!

Yes, I would install Proton VPN, I have it on my computer. I do not believe that the Proton VPN install caused the problem. But if it happens again (which I do not think it will) you should contact Proton support.
But I really think it was some sort of anomaly.

1 Like