CNIX notes

How did your install go?
Have a question?
Do you have suggestions for the Team?
Great Ideas?

CNIX is running well on Lenovo Flex15 (touch-screen). Also running well in a virtual machine on Dell OptiPlex 7040.

This note is posted from CNIX running virtually on Dell hardware with Brave Browser installed to CNIX-XFCE from the terminal.

XFCE is surprisingly fast and efficient.

I have never used this Desktop Environment (DTE) before; preferring Mint, KDE and Gnome.

Becoming a convert with CNIX as XFCE is easily customized, distraction free and the workspaces in the top panel is brilliant!

Question: When logging in I have to enter both my user and password.

Is there a setting for the default user or user management?

I’d like to be able to choose a user to login rather than typing it.

Great Start with CNIX!

Thank you!

As for the choice of user in XFCE… it is that way by default for security. However, you can fix that :smiley:

sudo vi /etc/lightdm/lightdm.conf

Find the below line, and uncomment it, then save the file.

Now after saving, restart your system.



Yep … I downloaded, and Installed it on the last winder’s machine I had …that had been tucked away unused since I started paying bills using only Linux about a year and a half ago … Haven’t had much time to look it over much yet, easy install and every thing worked right out of the box … on a cheap lenovo Flex 5 … has only 4gb ram which can not be upgraded … The 128 SSD hard drive cand be upgraded … Evey thing seams to work fine and they pre-loaded a lot of goodies … some of which are new to me … I will circle back and add more later … I copied this from a post made a couple days ago … and still have not found the need time to really look at it … Like NorseMan … that log-in was a road block which caused me to reinstall the OS because I messed up… misspelling the name I used as user account enough that starting over was the fastest way to fix it … Thanks to mcron … I can check off the #1 of my “things to do” list

1 Like

Thanks for this!
I imagined it was a best practice “security” choice but still wanted to be able to adjust the setting.

NANO is a bit easier for me so…
sudo nano /etc/lightdm/lightdm.conf
I found the line you mentioned at line 110 of 171

That made things a bit sweeter for my virtual CNIX!

I have been having fits trying to get the python development stuff working on CNIX. Probably something I am doing wrong. When I have something more concrete I can post about it.

1 Like

The base is installed on my CNIX though I have not played with it yet:

which python3

Yes, the base runtime is installed. It is the python-dev, pip, and then add on packages such as requests, httplib etc where I am having problems.

Interesting… I code in Kate and have never been an IDE guy.

CNIX ships with Geany, a basic integrated development environment (IDE) so thought I’d give it a go…

Loading a “hello” in Geany and delighted to see the variables neatly listed on the left with the line numbers they appear on.

Running “Execute” produced and error…
/tmp/ 7: python: not found

Meanwhile if I run the script from the terminal it runs fine (with chmod -x so it will execute).

Turns out that Geany 1.38 as shipped with CNIX, needs the build commands updated:
python3 is installed so the bulid command needs to be updated by adding the “3”.

To use Python3 with Geany just update the Execute command from python “%f” to python3 “%f” . Press the F5 key or choose Build->Execute

This doesn’t fix PIP or the development libraries though it does suggest there may be settings tucked away.

I still prefer my plain text editors to code.

CNIX is introducing me to lots of new ideas worth looking into.

Hope this help some newby CNIX-Pythoners

Yes, fairly common with any distro currently (at least the ones I have played with) to have that python3. Regular python is version 2 typically. I know you love Nano, but after nearly four decades of vi, I will just jump straight to vim in a heartbeat. :smiley:

1 Like

Spent a little time with the CNIX OS today …… messed it up and started getting errors when I ran update and upgrade …. after making it worse, gave up and did a reinstall …. anyone notice “Ibus Notifcation: Keymap changes does not work in plasma wayland please use system settings 5 instead” looked it up … debian-12 shows spurious IBus notification and a tray icon · Issue #8286 · QubesOS/qubes-issues · GitHub QubesOS was also based on Debian 12, so I looked here first …. also both times that I have installed it the clock was off by 6 to 8 hrs …. wondering if this was related … any one else run across this ? after reading at the link decided it was well above my level … is this something local to my system or just a glich to be ignored

yes saw that in both QEMU/KVM install and on Lenovo 15.

Ignored it and have not seen the error since. Ran a sudo apt update && sudo apt upgrade -y a few days ago with no issues after upgrade success.

My clocks are correct though I may have had to update the local-but not sure if that was CNIX (I am testing Garuda/XFCE as a comparison to CNIX as have no XFCE experience.

1 Like

Just started it up again and it had reset back to what I assume was what it was before I reset it last night …

ran an update and upgrade

fixed most of it …

searched on Brave and after going through a few posts found this:

update and upgrade seems to be ok now

1 Like

I am getting my CNIX install tuned up and surprised that git is not installed.
python was installed with inkscape so I don’t know if it was in the base install or not.
Screen sizing feels like it is optimized for laptop screens, the tools in the panel bar graphs are wider than I am used to.
I like it!

Thanks everyone, a lot of work went in to the first release of CNIX, but it’s still the very first release ever.

We are looking forward to steady incremental improvements in 2024!

1 Like

Installed easily and runs well on a 2013 macbook air, with 4 gig and a 128 gig ssd. I had to install a driver by hand to get wifi to work, during install it was hard wired. Good stuff!

I also had the raspi firmware issue, easily resolved per the above.

1 Like

Not totally sure if this is a choice of the JeffPro team but I recall reading that gitHub had been bought by Microsoft and that the team was avoiding gitHub in favour of an alternate FOSS tool. I can’t recall the preferred site.
Certainly a stumbling block as I have been using gitHub for years without understanding the new ownership!


I ran:
sudo dpkg --purge raspi-firmware
sudo apt update && sudo apt upgrade
and rebooted CNIX
Everything running well.

1 Like

Would love to get a chance to read the Team’s build notes … choices made, and reasoning behind them … just got home from getting a 2TB SSD to replace the 128Gb original drive … going to reinstall it again … this time putting Home folder on a separate partition …

1 Like

GitLab I believe is the preferred now, at least that is what JP has been promoting to the Python group. Yes, GitHub was purchased by Microsoft.

1 Like