Cinnamon stoped working on linux mint

I managed to intall linux mint on a Lenovo yoga 700 from 2016. It worked without problems on the first 3 weeks, I could install and uninstall several applications on it and manage to prepare it with the tools I needed to work like I did before on windows 10. So that was a big win for me.

Yesterday I was going to log in and everything seemed normal, but cinnamon had stop and the only thing that I can see is a black screen and the mouse pointer. I wonder if anyone can help me solve this. Thank you in advance.

Hello Marco!
This is strange - as Cinnamon doesn’t like doing it by itself. Speaking of which, can you reboot (or start your system) and press Shift or tap the Escape button as your system is booting so that you can come on the boot menu. Then select the Advanced options and select the “Recovery” boot option (the 2nd from the top).

At the menu that comes up later, can you please type the following command and post a photo?

inxi -Fxxxrz

If you get a message that the command is unknown, then you can install it via:

sudo apt install inxi

This may give us a general idea. :slight_smile:

Thank you @vasileios for the quick answer. Actually I’m working with a dual screen system but only have the secondary screen as the working one, the laptop screen have the liquid critals damage and it doesn’t work. The system identified it I had to turn the secondary one into the main, I didn’t give previously this explanation to not alongate the main message.

I’ll still be able to access the boot menu on the secondary screen?

Hello @vasileios!

Thank you again for your quick answer. I couldn’t access the boot menu cause I can’t see it due to my laptop screen is damaged and it doesn’t appear on the second screen. One thing I stumbled on stroking some keys trying combinations from windows I manage to access the tty4 (hope did not get the name wrong). Can we solve this on the tty4 or I’ll have to replace the screen on the laptop?

Hey @Marco!

This is going to be a tricky part. Unless your laptop has a key to disable the primary screen that works the moment you turn it on, you won’t be able to see the boot screen. Is it completely off or is there something you can see?

Hey @vasileios!

I can’t see anything on the screen of the laptop, the liquid crystals are almost all death, I see that it is working because there is some light on one corner but can’t get any info from it.

Thank you again for your assistance, kudos.

1 Like

Since you mentioned that. Perhaps some update shifted your main login screen to the laptop side, that’s why you see only black on your second screen. When that happens, try to hit Enter, type in your password and then hit Enter again. Perhaps this will allow a “blind” login. :slight_smile:

Thanks @vasileios once again!
I tried the blind login but I get the same result, a black screen with only the mouse pointer.

When I press “Ctrl” + “Alt” + “F4” thought I have access to the tty4 console (picture included)

And when I press “Ctrl” + “Alt” + “Delete” it exits the tty4 console, the system seems to reboot and some times it appears this screen.

I tried to login but it won’t let me do it with any of the several combinations I’ve tried. My normal login, boot secure login, etc.

Hope the pictures help you have a better perspective.

Thank you so much again for your pacience with everyone here and with me in particular.

Once again I missed some details, let me try from the begging.

When I start the computer this is the screen I get, the normal one.

If I move the mouse to the right it appear this other one.

So I can login normally, but I noticed that the cinnamon simbol on the top right of the login window is missing, that’s why I said cinnamon had stopped working.

When I login like usually used to do, it goes the black screen with only mouse pointer.

Hope this helps, I’m clue less what can I do next.

Surprisingly I could brake the mistery of the tty4 login as you can see in the picture.

I hope you can see the photos and sorry for not being print screens.

I hope this info helps with this mistery. :blush:

Okay, so your graphic environment appears to be working via the login-greeter (LightDM). This is good.

Since Cinnamon appears to be - somehow - missing, we can reinstall it.

Since you achieved it before, go to another TTY window, login and type:

sudo apt install --reinstall cinnamon

And see if you can login normally, without the black screen. :slight_smile:

1 Like

Flawless, it worked like a charm. Thank you so much for your help @vasileios. :pray:

This was also a lesson that I’ll keep for future reference, kudos.

1 Like

My pleasure, @Marco! Enjoy! :smiley:

1 Like