Cinnamon download Integrity check

How do you generate the local ISO SHA256sum? I downloaded Linuxmint Cinnamon 20.3 and the files sha256sum.txt and sha256sum.txt.gpg for a MacBook Pro late 2011. Then opened Terminal and typed sha256sum -b linuxmint-20.3-cinnamon-64bit.iso. The result is -bash: sha256sum: command not found. I’ve tried dozens of times, varied without spaces, etc., and all result in command not found. Hope someone knows what I’m doing wrong. Thanks

You can get a simple lil app called GTK-Hash (should be able to download in software mgr) then follow below instructions for ShaSum checks (which when downloaded from actual official distro website would VERY RARELY be corrupted) which can be needed for random downloads off github and small sites maybe.

Once downloaded open it and follow steps in red - in order

Hope it helps

1 Like

In the terminal, you may not be in the same directory as the .iso file. If this is the case then cd to Downloads, or wherver you put the .iso and then run the command.

Thank you both! I tried the Gtk-hash but couldn’t find an iOS one that I could download. Tried cd downloads and got the same “no command found” message. I found an online hash and it passed integrity check.

I’m having the same trouble with the Authenticity check with the same “no command found” message. Tried many times checking accuracy of keystrokes and tried the second version when the first one didn’t work. The signing key sounds important.

I have the files in the Download folder. I’ve tried entering with cd download and without. Seems like it’s Terminal or iOS problem?

I’d say by-pass the integrity check - IF you downloaded it from

with other cases, once you HAVE MINT you can go get GTK and use, but it would be an extreme rarity for their site to be hacked and iso messed with.

Now that i understand you are on iOS, and have the file in your downloads, it sounds like you are ready to proceed with install (have all files you care about, backed up on thumb drive) and just not sure how - am I correct?

If that is the case - then you can go get Etcher which is the program you will install ONTO a new clean (already formatted fat32) thumb drive. I know Balena/Etcher is available for iOS and you can find here balenaEtcher - Flash OS images to SD cards & USB drives
then we can move forward once etcher is on your thumb (zip) drive.

Did you type “cd downloads” or “cd Downloads”? The former would give an error because the file structure is case sensitive, and you would not end up changing directories

I did use a capital D and had the same results

I did download from, so probably fine.

I downloaded a file named from balenaEtcher - Flash OS images to SD cards & USB drives and have it on my thumb drive. I couldn’t resist clicking on it, and a new file appeared with .cpgz on the end. ??

Just so you know why I’m so slow, work full time and due to very limited HughesNet internet in rural Alaska, I download large files and updates late at night.

Sorry for mis-speaking, what i meant was to INSTALL it (Etcher) onto the FlashDrive - not just move it there. So now delete those files on your thumb(flash) drive because it sounds like you may have the wrong one anyway if it is a ZIP.

Because, I thought you were doing this on a Mac/Apple iOS?

You would need to scroll down from the top and choose the Mac version - which should be a .DMG then we can move forward.

This guy walks you thru install if you need that How to install and use Etcher | Free USB tool for Windows, Mac & Linux - YouTube

This may bit a little late, but I have an answer to the first part of your problem. I also have a MacBook Pro, earlier model, and there is no sha256sum command. However, there is a shasum command, and if you type shasum -h, you’ll see the help topics and you will see that you can add the desired parameters, including specifying “256”. So the actual syntax you would use is: shasum -a 256 myfilename.iso.

I’m also having the authenticity check problem. GPG must be a command that runs on Linux systems and it won’t be found when running the command on Mac systems. I haven’t found an answer yet on how to verify the authenticity of the sha256sum.txt file.

Thanks! I figured the sha command was missing from this old machine. I did an online version at After some trial and error I checked the sum and it matched, so I was confident enough to move on with help from QuriousPatriot and mace. I didn’t bother with Authentication.

Went on to making a bootable stick. Where I stalled out. Getting back into it fraught with problems. I’ll respond to QuriousPatriot on those

Stuck on making a bootable stick. I downloaded BalenaEtcher and have it installed on the MacBook laptop. I tried different ways to install it on the stick, but nothing worked. Then I tried using etcher app, grabbing the Linux os and sending it to the stick. Appeared to work, but it is not bootable. Tried having iOS format a bootable MSDOS FAT but that wasn’t the answer. Maybe it is important to have a brand new stick, in which case I will need to order, none in my local area. Maybe I still need to get Etcher installed on the stick?

Read up more on making a bootable stick with Etcher and I followed it correctly. Maybe all the trial and error corrupted the stick. Still thinking, my next step is ordering more sticks, a two week or more delay. Thanks for everyone’s help

@pathey Did you see my reply from yesterday regarding the shasum command on earlier Macs? Shasum -a 256 myfilename.iso works.

Btw, I’m also stuck on making a bootable USB. I’m pulling my hair out at this point. Rufus doesn’t work on a Mac, and I confirmed this with the developer. Etcher…it seems to have many many problems and one YouTuber with a large following says he no longer recommends it, because of some “shady” things going on with it, like a lot of background network traffic while running it.

Usbinstaller is another one, but I can’t find the sha256 numbers to verify before downloading from Github.

Ventoy also doesn’t support MacOS.

This is beyond frustrating. I’ve been watching videos and following Jeff’s courses, but have yet to be able to get a Linux ISO from my MacOS to usb drive, in order to format old Windows laptop.

@Mandie yes, I did see your reply. So, I’m still stuck in the same place. I have tried Etcher with different 16gb thumb drives and tried to make bootable stick with iOS. Nothing works, so ordered new thumb drives, since the used ones might have formatting that prevents them from being set up as bootable stick. If Etcher is a problem, I’ll search for alternative. I read that it can take up to four months for newbies to get it. hah! I might be slow learner, but will keep trying and post here if I find something that works

In most cases this has been because of a BIOS setting.

See if you can look up your Mac model and research how to get to your bios. You will generally have to go to hardware tab choose your USB to be your boot drive, then save (generally F10 - but read screen) and exit.

Then you will also need to research how to enter BOOT ORDER on your comp (generally a different key than bios) and set USB as the first item on the list there also

I have personally never done a Mac, but on PC windows machines I know you have to also turn off UEFI temporarily which is also in the BIOS

This fellow though not the easiest to understand, walks thru most of it - CAN`T BOOT FROM USB FLASH DRIVE? 100% ANSWER! BIOS & UEFI - YouTube

Sorry I haven’t been responsive. I found much needed work after being laid off for 16months, so I can’t be around as much here. But I need it bad so, I thank GOD it came finally

1 Like

I found a tutorial that explains better using Apple Disk Utility to make the stick bootable, “Erase,” “MS-DOS (FAT),” “GUID Partition Map,” click “Erase.” Then use Etcher to flash iso. When you get the pop up, the last trick is to “eject,” shutdown, insert stick, press and hold “Option” during power on. I don’t get in, checking my wifi and then back to the stick set up. I feel I made progress

@QuriousPatriot Thanks! I will check the bios next. Glad you found work

1 Like

@Mandie Well, I got it! Installed Linux Mint Cinnamon on a 2011 MacBook Pro. It was just “user error” on opening the stick. So the stick was fine, the download was fine, and the bios and Jedi were fine. This is where I had trouble, Restarting the laptop after using Etcher to flash the stick, hold the “option” button while powering on. Choose the arrow below the drive that holds your distro stick and the live session opens. I opted to install Linux Mint on the computer, but somehow I missed connecting to the internet and there is only wired option that I can find. I’ll reinstall to see where I missed it.

1 Like