Changing distros

@vasileios I have been using mint on the computer that I am on right now. I want to put Zorin on - dual boot or replace Mint with Zorin. No matter what I do I cannot seem to be able to choose the USB that Zorin is on and I have USB chosen on EFI and Legacy, but it just boots to the Mint installation - every time. What screen shots of the BIOS do you need to get me out of this?

I can’t walk you through it on your computer specifically but I feel like it is probably in the BOOT ORDER that you have the hard drive chosen first so therefore it never gets to the USB. You DO need to do those other things as well, but you also must tell it where to boot first. I would use a search engine of your choice and look up a video on how to boot into your BOOT ORDER on your specific make & model of computer - most likely it will be achieved from tapping a “F” key repeatedly - but every brand and model gets into BOOT ORDER a different way. Hope that helps


@QuriousPatriot thank you I will try that. The BIOS is not even seeing the USB drive when it starts until Mint loads. I will keep trying. Cheers!!


Hey, @BigDaveAZ!
You will essentially need to activate UEFI directly from within the BIOS. Some distros flash the Live USBs only with UEFI, so the Legacy BIOS boot cannot detect them. Others, like Arch - for example - flash the USBs with a dual-booting system and they automatically detect what kind of booting mechanism your system has (BIOS/Legacy or UEFI), and it lets you now immediately from the get-go which version it is you’re using.

@vasileios here are the BIOS screen shots. legacy is enabled as I just switched it on to see if that worked.

the above is the boot option menu - no USB available to choose

I really want to try a new distro - Zorin, for now. I may have to find a blank CD and burn the iso with etcher and try that if we cannot get this working. Cheers!!

@vasileios I am really at a loss on this one. Please inform me of the incredibly simple, easy, no way I should have forgotten, step to fix this. HAHAHA!! Cheers!

Hey @BigDaveAZ!
How about pressing the Escape key during system start so that you get the boot drive menu? In that area, it will show you the actual USB drive. If it’s not visible, then something must have gone wrong with the recording. It’s not unheard of.

Worst-case scenario, try recording Zorin again with Gnome Disks and see how that goes.

@vasileios I have tried multiple drives, just in case, it does not see the USB at boot. I am also having trouble finding a burner software that will do 16x - otherwise my CD/DVD is not big enough
[EDIT] Looks like kb3 is working. :crossed_fingers: :crossed_fingers:.
I just tried LMDE on a USB and it doesn’t find it either. Let’s hope the DVD burn works Cheers!!

1 Like