Can't install NORDVPN on Ubuntu 18.04

I get the Whoops! /run/nordvpn/nordvpnd.sock file Tried reinstalling… tried many suggestions online… my nordvpn was downloaded to my download directory. Cant find anywhere where this nordvpnd.sock comes form or how to install it.

Hey CJ,
I had the same issue when I installed Ubuntu, but the 22.04.

Try this step-by-step approach. I think this is the one I used:

Yes I was using these instructions too. The only part I ignored as I didn’t think it was my problem was the permissions part. Maybe I need to understand that better. Thanks

This worked for me in Kubuntu 22.04.2 LTS x86_64
It seems that the upgrade changed the protocol
Setting to UDP worked!
Type the following commands into the Terminal window:
nordvpn set technology openvpn
nordvpn set protocol udp

Should the issue persist, please execute the following commands to reset the NordVPN Daemon:

sudo systemctl restart nordvpnd && 
sudo systemctl start nordvpnd &&
sudo systemctl enable nordvpnd

FIXED ! my version of Ubuntu is 18.04 LTS and is uses GLIBC 2.27-3 and the latest version of nordvpn using GLIBC 2.28 so I had to install and older version of nordvpn, nordvpn_3.15.5. This was suggested at Reddit - Dive into anything