Cannot upgrade as EFI Partition System not usable

Hello everyone.

I’m on Ubuntu 20.04.5.
i try upgrading but only get the option to “partially upgrade”.

(see pic.

When i click on it, it gives me the following notification: “efi partition system not usable”… “Your EFI System Partition (ESP) is not mounted at /boot/efi. Please ensure it is properly configured and try again”. (see pic.

Now if i check at /boot/efi directory is empty!

Any idea what would cause this issue?

thank you…


Which particular way are you trying to upgrade? CLI or USB with a new release? Have you checked to see if UEFI is enabled in BIOS or Legacy Mode?

See: EFI or MBR

i was trying to do a sudo apt update && sudo apt upgrade…then tried with software update

ive just checked … in the Bios im on UEFI

thanks for the link … after typing sudo parted -l i get this …GPT both disks …by the way, Ubuntu 20.04.5 is on /dev/sdb ATA SPCC solid state.

also when typin sudo gdisk -l /dev/sdb iget this:

Did you happen to screenshot what “sudo apt update && sudo apt upgrade” returned?

when i update at some point during the process i get this :

so i only can enter “ok” and get this:

press “yes” … upgrading would succeed but i’ve noticed that after rebooting and doing " uname -a " i am still on older kernel instead of

a screenshot of terminal once upgrading done.

if i click “no” instead of “yes” i would then be sent back to screenshot 1…

Now after rebooting uname -a still tried a sudo apt update result was 19 packages can be upgraded … did sudo apt upgrade …installed but when typing again sudo apt update i still get the same list of pkgs…

Seems that they may have unmet dependencies or something:
Read here for similar: Packages held back

Cautious solution 1:

Per Pablo’s answer, you can run sudo apt-get --with-new-pkgs upgrade, and it will install the kept-back packages.

This has the benefit of not marking the kept-back packages as “manually installed,” which could force more user intervention down the line (see comments).

If Pablo’s solution works for you, please upvote it. If not, please comment what went wrong.

Cautious solution 2:

The cautious solution is to run sudo apt-get install <list of packages kept back>. In most cases this will give the kept-back packages what they need to successfully upgrade.

Thank you so much MrDeplorableUSA for your help. :pray:
Couldn’t fix the issue so I finally re-installed Ubuntu from scratch … i probably did some wrong last time when partitioning during install…this time i left ubuntu installer do the job instead. Now ev’thing works fine…

Sorry you had to do that.
Hopefully you didn’t loose much.
I try to avoid gpt/uefi but one day I’m sure I’ll have to deal with it. I’m also not much of an Ubuntu fan anymore due to snaps, its a good starter distro for newcomers but so is Mint(also Debian/Ubuntu based) but no forced snaps.

oh no worries, ive just installed 2 weeks ago, i did not loose anything, actually im on a fresh install and it finally works fine…i unfortunately need using 2 apps that only exist as snap version …
again MrDeplorableUSA, a big thank you!

What 2 apps are those?

im using Authy & Tradingview but im now testing another 2fa app called Authentificator* (its a flatpak (but at least it does not asks a phone number like Authy)…pb is i was getting an error restoring the backup file (a text file). Since i’ve re-install Ub 20.04.5 and deleted my second disk (w/22.04) i now have efi correctly located @ /boot/efi and i dont get this issue anymore when restoring Authentificator’s data …

*actually i got introduced to Authentificator thru Jeff’s TG channel…

1 Like