Calibre version 4.23.0 install doesn't work

I have a new project. I decided to try to save all my Kindle books in Calibre on my computer. Long story short – the new version of Calibre (5.30) doesn’t work with the plugin deDRM. They suggest installing version 4.23.0 because that’s the last version that worked with deDRM.

Are there simple instructions somewhere for installing an older version of Calibre? I’ve tried pretty much everything. I even installed it from downloading a tarball file, but when I tried to open it, it just doesn’t do anything. I’ve tried every suggestion on the Calibre site multiple times. I’ve reinstalled 5.30 and tried to roll it back to an earlier version. I’ve tried to install version=4.23.0 from the site, but it says no file exists so it has to be manually downloaded onto the computer. I assume I’m missing a step.

I downloaded the .txz file onto my desktop. Then I used this:

sudo mkdir -p /opt/calibre && sudo rm -rf /opt/calibre/* && sudo tar xvf /path/to/downloaded/calibre-tarball.txz -C /opt/calibre && sudo /opt/calibre/calibre_postinstall

I used the path on to my desktop file and it downloaded the file, but when I try to open it, it sits there for a second and then closes.

Calibre doesn’t help me much unless I can get it to work with deDRM!

Thank you!

Hey @MStapleton!
I apologize for my late response. I’ve been “on the warpath” to decipher issues with VPS and email servers. It would appear the problem was in the domain records. Anyhow, I just downloaded Calibre 4.23 and it would appear that it indeed has a lot of executables to make your head spin. However, there might be a simple version.

Perform the following command and please let me know how it goes:

sudo -v && wget -nv -O- | sudo sh /dev/stdin version=4.23.0

(It’s a two line code, so make sure you triple-click to select it all)


If that fails, there are the newer DeDRM plugins that should work with versions 5.x.

You can download the ZIP file and then follow the plugin installation instructions. :slight_smile:

Thank you so much! Got the new version to work and all is well. Appreciate your time and support so very much. I feel so much better having control over books I’ve paid for.

1 Like

You are most welcome & yes, I completely agree! :slight_smile:

It works…almost.

  • Calibre v5.32
  • Plugin: DeDRM_tools v7.2.1
    (using instructions, filename “DeDRM_plugin_ReadMe.txt”, from unzipped download)
  • Plugin: KFX (as referenced in above .txt)
    on Mint/Cinnamon.

The hardest part was finding Calibre’s “Preferences” button in order to access “Plugins”. There’s a 2nd layer of menu icons available by clicking the 3 dots here:
calibre preferences

calibre plugins

With this process, Calibre adds DRM’d books to the library, but does not de-DRM or open them. Thus, there’s no file conversion.

cannot convert

What’s my next step?
Many thanks!

It would appear there are some issues, depending on if you read the book before or if the file has not been updated.
There is a reference to that on the following link:

I believe one of these sections will cover you.

Thank you, Vasileios.

1 Like