BusyBox Boot Issue (initramfs)?

I am having a Busybox boot issue. I had Zorin 16 Lite installed and it was running fine and I decided to switch to Mint Cinnamon 20.3 so I booted from a Live USB stick and installed.
Everything when fine during the install and then on removal of USB and reboot, I get stuck in BusyBox with this message:

BusyBox v1.27.2 built-in shell (ash)
Enter ‘help’ for a list of built-in commands.


This is the only thing in the BusyBox terminal, there is nothing above this message to point to where the problem may be.

I have looked online and I have tried the instructions I found:
fsck /dev/sda1/ -y (also tried sdb1 in place of the sda1)

Nothing worked.

I thought it may be something corrupted in the Mint install so I tried to go back to Zorin 16 Lite and now I get the same thing with that as well.

How do I get past this during boot and fix so it will not happen anymore?
Thanks, Jeff

Hey Jeff,
Perhaps this article can help with your issue. Keep an eye for the actual device name for your boot partition, as you’ll need it for the repairs - since the article referes to Ubuntu (Zorin and Mint are Ubuntu based as well).

I trees that and it did not work.

Here is what I am seeing now.


(initramfs) fsck /dev/sda5/
sh: fsck: not found
(initramfs) reboot
(initramfs) exit
I Gave up waiting for root file system device.
Common problems:

  • Boot args (cat /proc/cmdline)
  • Check rootdelay= (did the system wait long enough?)
  • Missing modules (cat /proc/modules; 15 /dev)
    ALERT! /dev/sda5 does not exist.
    Dropping to a shell!
    BusyBox ¥1.30,1 (Ubuntu 1:1,30.1-4ubuntu6, 3) built-in shell (ash)
    for a list of built-in commands


In this scenario, I’m suspecting that the actual kernels are missing from the /boot area of your drive, which leads to having these issues.

When you installed Mint (that started this issue), did you select any manual partition?

Also, is your system a single drive or multi-drive?

Last, but not least, are you dual-booting with any other operating system?

I apologize for the questions. I’ll need some insight as to what may have caused it.


Thanks for your help.
I did not select any partitions. When asked the question during install if I wanted it to try and unmount the existing drive, I told it yes.

It is not a multi drive unless you are talking about possible other partitions.

Also, I am not dual booting.


Hey Jeff!
You’re very welcome!
From the screenshot you sent, I’m thinking if you selected to encrypt your drive - as I see the LVM (Logical Volume Manager) enabled (the “extended” partition - which gives you the sda5). Even if you don’t have LUKS encryption, the LVM requires quite a different approach to load.

If you don’t have any important files, I’d recommend you re-run the installation of Mint by using the default disk partitioning options and see how it goes.

I have already tried that multiple times and this same thing keeps happening.
I did thy loading up from a Live USB and running Boot Repair and this is what I got.

Update with this issue.

I have tried several more things from trying to repair using GParted which did not work.

Then I found these instructions and tried them as well.

Boot into a live CD or USB and find out your partition name by using

sudo fdisk -l|grep Linux|grep -Ev 'swap'

List all superblocks by using the command:

sudo dumpe2fs /dev/sda2 | grep superblock

Where the (sda2) above is your drive name

You should get a similar output like this

  Primary superblock at 0, Group descriptors at 1-6
  Backup superblock at 32768, Group descriptors at 32769-32774
  Backup superblock at 98304, Group descriptors at 98305-98310
  Backup superblock at 163840, Group descriptors at 163841-163846
  Backup superblock at 229376, Group descriptors at 229377-229382
  Backup superblock at 294912, Group descriptors at 294913-294918
  Backup superblock at 819200, Group descriptors at 819201-819206
  Backup superblock at 884736, Group descriptors at 884737-884742
  Backup superblock at 1605632, Group descriptors at 1605633-1605638
  Backup superblock at 2654208, Group descriptors at 2654209-2654214
  Backup superblock at 4096000, Group descriptors at 4096001-4096006
  Backup superblock at 7962624, Group descriptors at 7962625-7962630
  Backup superblock at 11239424, Group descriptors at 11239425-11239430
  Backup superblock at 20480000, Group descriptors at 20480001-20480006
  Backup superblock at 23887872, Group descriptors at 23887873-23887878

Choose an alternate superblock from this list, for this case alternate superblock # 32768

Check and repair a Linux file system using alternate superblock # 32768:

sudo fsck -b 32768 /dev/sda2

You should get similar output like this:

fsck 1.40.2 (12-Jul-2007)
e2fsck 1.40.2 (12-Jul-2007)
/dev/sda2 was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong for group #241 (32254, counted=32253).
Fix? yes
Free blocks count wrong for group #362 (32254, counted=32248).
Fix? yes
Free blocks count wrong for group #368 (32254, counted=27774).
Fix? yes
/dev/sda2: ***** FILE SYSTEM WAS MODIFIED *****
/dev/sda2: 59586/30539776 files (0.6% non-contiguous), 3604682/61059048 blocks

When done, try mounting the partition

sudo mount /dev/sda2 /mnt

Try to browse the filesystem with the following commands

cd /mnt
mkdir test
ls -l
cp file /path/to/safe/location

If you are able to perform the above commands, you have most probably fixed your error.

Now, restart you computer and you should be able to boot normally.

I tried this and everything seemed to work so I rebooted and go the same (initramfs) error again.

Then something very strange happened.

On a whim I decided to try a totally different Distro. I put in my live USB stick with Ventnoy and about 20 different distro .isos on it and I chose (Manjaro Deepin).

This installed with no problems and when it rebooted it came up with no problems and I was able to use it without a hitch.

So I figure that my problems are solved and I thought I would just try reinstalling Zorin since I know it worked originally.

Well I tried that and now I am back to my original problem getting stuck in BusyBox with the (initramfs) error.


This is indeed a peculiar error to be facing, especially with new installations.
How about, before you install Zorin, you go install GParted (it will allow you to do it, on that boot alone) and then delete everything from your main drive (all partitions)?
Since you’re getting stuck on InitRAMFS, it means that specific setups land on a possibly corrupt area of your main drive. Are you using an SSD or an HDD?
The reason I’m mentioning this is that some distros tend to differ in partition formats on the boot sector. I used to have an older SSD in the past which presented a good amount of errors near its end region. So, as long as I would disallow the partition to cover that space, the SSD worked normally. Therefore, some of the distros you’re installing are landing on a corrupt area of your drive, hence the filesystem there becomes corrupt and ends up with you having to deal with BusyBox. Note that bad sectors tend to spread too.


I will try that and see what happens.
I guess I would not have to install gparted if it is part of the Live USB distribution, I could just run it from within the Live Boot, Correct?

Should I delete every partition? Will this also delete the BIOS? I don’t want to do that,

I am on HDD.

It is kind of crazy that it will let me install Manjaro Deepin and it runs just fine but it will not run the Mint or Zorin install.



The BIOS rests inside a hardware chip, not on your hard drive, so you can safely wipe the entire drive (yes, every partition).

It is. The reason is that the Arch-based distros tend to use a different boot partition setup than the Debian-based ones (Mint and Zorin are both in that category). Also, the HDD bad blocks tend to spread. All it needs is for a single bad block to go bad and “land” on the location of your HDD’s filesystem block area to cause the corruption. Even with Manjaro, in the case of hardware issue, the problem will eventually catch up.

If you have a spare drive, try connecting it to your system and try an installation. I doubt you’ll encounter this issue again.

I am about to give up.
I tried your suggestion and through a live boot I used GParted and deleted all partitions and then reinstalled Zorin 16 Lite and I got the same result into BusyBox.

So then I tried deleting all partitions again and and installing Manjaro Deepin since that worked before.

It installed and rebooted and seamed to work.
Said therer were updates so I let the updates install and it had to reboot at the end of the updates.

After rebooting it never started, it just set on black screen with a flashing curser.

I then tried to reboot into live USB and now it does not even boot to the USB stick it takes me straight to this.

Hey @Gr8_4w4k3n1n9,
I am strongy suspecting some hardware issue here. The fact that you were stuck on a black screen with just the cursor blinking means that the drive got stuck trying to access files.

Per the USB not booting, that’s… interesting to say the least. What year is your laptop from (and its specs)? The reason I’m asking is that you might be experiencing actual hardware issues - which is not unheard of. I had similar issues with an old Sony laptop a few years back.