Boot is to long on linux Mint

The boot on my computer is taking longer than 2 minutes. I search all over, fdisk permission is denied.
Here is the systemd-analyze
Screenshot from 2022-08-02 19-28-16

can some one help

what are the system specs other then LM 21? Ram, CPU, laptop with onboard video, desktop with onboard gpu or separate gpu card?

run systemd-analyze blame and it will give you a more detailed output.

here is the system-analyze blame this morning. my computer is an old Lenovo w520 just change thew hard drive for a big one. 16GB virtual memory. Was running windows 7 a year ago when I star my journey with Linux

here is more information


I will appreciated any help

I’m not real certain on LM and your running 20.3 instead of 21 correct. Maybe someone with more experience on Mint can chime in. That 520 is newer then my 460 and 430 and my boots on Debian 11 are nothing like that.

Much post installation customization?

Hey @Shuflo,
Your drive is a 2.5" HDD that was built in 2013. Those drives are quite slow, so I’m not surprised it takes that long.
The other two that it’s waiting for - besides the drive itself - are the network and the GPU. For the network, it might be waiting for the network to come online, which can be quite the pain to wait on. Can you send the output of the following command?

sudo systemctl list-unit-files | grep NetworkManager

I want to see if the “Wait for Online” service is active.

As I suspected! :laughing:
Do a:

sudo systemctl disable NetworkManager-wait-online

And do a reboot. This may save you a decent amount of boot time. The only downside of it is that your system will begin the process of logging into your WiFi the moment your login greeter appears.

Other than that, it’s an HDD issue. The 2.5" ones tend to be quite slow when it comes to file/sector seek time.

Well I did only save about 15 seconds and I have no internet connection at all…

Then I’ll revert to the previous assessment. It’s a drive issue, not a software one.

By the way, you can re-enable the service by executing - in terminal:

sudo systemctl enable --now NetworkManager-wait-online

Thank you so much. I believe it is because I change the drive to a bigger one It was an old apple I had with more memory I need. So I think is an SSD, I’m right?
yes I revert before, you sent the message. Again Thank you so much for the help. I guess I will have a minute and 45 seconds boot.

1 Like

An SSD will do wonders for the boot time. And since Mint is very user-friendly, it tends to load a lot of services, which makes it slow on old HDDs. And you’re most welcome!