Bluetooth Speaker connects for 2 seconds

I have a new bluetooth speaker that I’ve successfully paired with my laptop running Cinnamon Mint. When I turn on the speaker, it does automatically connect…for 2 seconds. Then it disconnects. The only way it will stay on is if I open the Bluetooth connections on the laptop and manually turn the speaker on. It then stays connected until I turn it off. I’ve searched videos and forums and don’t find an answer to this specific issue. Reading the manual that came with the speaker doesn’t provide any answers. The speaker is Oontz Angle Solo. I’d appreciate any tips or info about where to locate a solution. Thanks!

I was having a similar problem where Cinnamon 19.4 wasn’t seeing my Wi-Fi 6 Bluetooth 5. 2 Intel AX210 card. I updated to Cinnamon 20.2 and it had updated drivers and now my WiFi and Bluetooth are working great.

1 Like

Hey @wizardcq,
There could be a number of reasons for that. One may be the idle settings of the Bluetooth. The other could be the Bluetooth manager.
Let’s go with the former and see if it works. Open up a terminal and execute:

sudo sed -i 's/#IdleTimeout=30/IdleTimeout=0/g' /etc/bluetooth/input.conf

Then do a:

sudo systemctl restart bluetooth

This setup has helped a few people on Ubuntu, so it should do something on Mint. Please let me know how that goes.

1 Like

Thank you and I will try this. I just got home from work and have a meeting in 45 minutes. I’ll definitely give this a go as soon as I get back home! :grinning:

1 Like

I know how to find the current version of my OS on Windows and on a Mac but not sure where to find it in Linux. @vasileios, I tried those commands and it didn’t appear to change anything. The first command line resulted in a query for my password which I entered. Then I entered the second command line and it just went to the next prompt line. For some reason, uploading photos doesn’t work for me. When I attempt to attach a photo, it just sits and spins. I’ve tried checking “small” and it still doesn’t work. ugh…

Processing: 01B81E1E-EF36-4F02-86ED-80038CB3E6A8.jpeg…

Then we may jump to the second option, which is the Bluetooth manager.

Here is a good article that may help you with your issue:

1 Like

Thank you! I appreciate the link!

Hi, @vasileios. I started going through the process recommended in the article. I did the first command line to check the status. It gave several lines, one of which includes active: (running)
Then it looks like this:
Dec 17 17:37:27 wizardcq-Latitude-3580 systemd[1]: Starting Bluetooth service…
Dec 17 17:37:27 wizardcq-Latitude-3580 bluetoothd[81591]: Bluetooth daemon 5.53
Dec 17 17:37:27 wizardcq-Latitude-3580 systemd[1]: Started Bluetooth service.
Dec 17 17:37:27 wizardcq-Latitude-3580 bluetoothd[81591]: Starting SDP server
Dec 17 17:37:27 wizardcq-Latitude-3580 bluetoothd[81591]: Bluetooth management >
Dec 17 17:37:28 wizardcq-Latitude-3580 bluetoothd[81591]: Endpoint registered: >
Dec 17 17:37:28 wizardcq-Latitude-3580 bluetoothd[81591]: Endpoint registered: >
lines 1-18/18 (END)
There’s a white cursor at the end of (END) and it appears to be doing nothing. When I try to close the terminal window, it tells me that there is still a process running. I’m going to bed and will just leave it as is until tomorrow morning and will see if anything has changed.
Left it all night and it looks the same. Closing the terminal window. :woman_shrugging:

Hey @wizardcq!
Apologies for my delay. Lots of ground to cover all around.
When you see the blinking cursor, there are two things you can mainly do.
First is to press “Q” to quit or CTRL+C to interrupt and stop.

Hi, No worries about the delay. I’ve got lots going on myself besides trying to troubleshoot a bluetooth speaker. :grinning:
Odd thing happened just a few minutes ago. I’ve been listening to podcasts through my bluetooth speaker that I’ve clicked manually to connect. Suddenly the speaker stopped broadcasting and the blue flashing LED on the speaker began flashing like it does when trying to connect. I tried to reconnect and found that my laptop was locked up. No response to any keystrokes. The only thing that was changed is that I saw an update for the Brave browser “click to relaunch” which I did earlier today. When my laptop was locked up, I had to do a hard shut down, then powered back up again. When I tried to launch the bluetooth, the bluetooth window says “No Bluetooth adapters found.” Something abruptly changed and I’ve no idea what it could be. Thanks for any help and no rush.

Ah, power management is giving your adapter quite the workout. I would recommend you go to settings and disable it - or at least disable the automatic suspend function. I trust a reboot will help fix things.

Please let me know if the issue persists. :slight_smile:

Hi @vasileios
I’m finally able to have time to get back to this. I went to Settings, clicked on Bluetooth and didn’t see anything about an automatic suspend function. There was only a list of devices. Am I looking in the wrong place?

Interesting. It could be a different Bluetooth manager that doesn’t pop up on your settings. I looked up and came up with the following link for you below. It covers a wide area, which could offer some resolution. Please let me know how it goes. :slight_smile:

1 Like