Bluetooth Issues

I have installed ZorinOS on a HP ProBook 650 G2. It has an Intel AC 8260 wireless card. The wifi is working fine but I can not get the bluetooth to function. I have a bluetooth mouse and can’t connect it because I can not get the bluetooth to turn on. So far I have been unsuccessful at finding anything online that has help me to get it functioning. Anyone have this issue that has been able to resolve it? Please let know thanks.

1 Like

Hey @Shane!
Let’s go with the standard process to find out which module you have.
Open up a terminal and execute the following command:


Please send me the output so that I can look up the desired module. :slight_smile:

Here you go @vasileios! Thanks for checking this out!

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #2 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #4 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-V (rev 21)
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
02:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

My pleasure, @Shane!
I believe I found the issue. You have a combo WiFi/Bluetooth card:

Intel 802.11a/b/g/n (2x2) and Bluetooth 4.0 Combo

Okay, this may be a bit challenging, but I believe there may be a solution.

From what I found in an Arch forum, this specific module tries to start early on and encounters a conflict with the same module’s WiFi. So, let’s shoot that pre-load out of the loading sequence. Open up a terminal and type in:

echo 'blacklist btusb' | sudo tee /etc/modprobe.d/blacklist_btusb.conf

Next step, we’ll create our own service that will initiate the Bluetooth. First, let’s go full Root so that we don’t get any accidental “permission denied” messages.

sudo su
nano /etc/systemd/system/restart-bt.service

This will create a new file. In it, fill in the following:

#systemctl enable restart-bt.service
#systemctl start restart-bt.service
#systemctl stop restart-bt.service
#systemctl disable restart-bt.service
#systemctl status restart-bt.service
#systemctl daemon-reload

Description=Restart Bluetooth Service

ExecStartPre=/usr/bin/sleep 3
ExecStart=/bin/bash -c "modprobe btusb; sleep 3; systemctl restart bluetooth"


The “#s” are just dormant commands - in case your Bluetooth acts up and needs a few restarts early on. For now, leaving the “#” there, just turns them into “comments” - so they don’t get executed.

Press CTRL+O and then Enter to save. CTRL+X to exit.

While you’re still Root, type in:

systemctl enable restart-bt.service

Then restart and check if it works for you. :slight_smile:

1 Like

Hello @vasileios, I had time today to sit down and try this out. It worked out beautifully! So glad to know you! Your skills are invaluable! Thanks so much for sharing your knowledge.

1 Like

Hey, @Shane!
I am truly happy this worked out for you and you are most welcome, my friend!
Now you see why I am in the forums most of the time. I can’t post these kinds of solutions on the TG channel without being kicked out by the bot! :laughing:

1 Like

I can see that, the forums are really nice for serious problem solving.

1 Like

We got lots of that going on around here. :wink: