AMD GPU driver installation - PLS help (Starting this as "A New Hope")


I’m trying to make sure that I’ve installed the driver for my AMD Radeon RX 6700 XT video card on Kubuntu 21.04. I’ve gone through quite a number of different tutorials / instructions, with not much progress. I’ve been able to get some Steam games to work, but they are not running perfectly (I mean, they run well, but in comparison with Win versions, they get a “B”). Still, they run, and they are not glitching.
However, I AM having issues with getting DaVinci Resolve 17 working, or, more precisely, seeing the video card as the actual physical card installed (i.e. I get Auto option only, no choice for Radeon or any kind, much less (what I assume to be) a capable video card.


Any help is appreciated! Any! If I can get the thing working, I would be super excited and grateful.

Thanks in advance.

  • Thorson

You can try this thread for your graphics card.

As far as games, are you using Proton at all?

Yes I am, that is how they are working now. But I’m still seeing artifacts in graphics. But no glitching / tearing. Just not nearly as sharp as the WIn counterparts.

Problem with most tutorials (one you linked included) is they are written for Ubuntu 20.04 derivatives. I am running 21.04, and AMD being AMD have not updated drivers for 21.04 yet. I found a YT video that was related to DaVinci Resolve which had a command that installed driver created by an Ubuntu developer. In case it helps anyone else, it is as follows:

sudo apt-get install mesa-opencl-icd

I just want to make sure DaVinci Resolve is working. I can deal with games being meh… I should be doing something productive with my life anyway!

Here’s this article I found that talks about DaVinci Resolve and AMD on Linux: How to install DaVinci Resolve on Ubuntu with AMD GPUs - CIALU.NET

And here’s another one with some information:

Great, thank you. I’ll take a stab at those and report what happens.

1 Like

As far as the games are concerned, a lot of them require some additional tweaking in order to work properly. For example, Path of Exile is sputtery with Proton if you use DirectX 11. But if you switch to Vulcan, its near perfect. Check for a full list of games and check the comments for tips on what to tweak.

Good evening, Tovarisch!
It would appear I’m a… vampire tonight! I had a late lunch, so I laid down, fell asleep, and here I am!
I had my own troubles with an AMD card and drivers. So, I have a bit of… bittersweet experience with them!
Do you happen to know the model of your graphics card?

By the way. AMDGPU PRO by AMD is very, and I mean very picky about the Kernel version. And since you’re running Ubuntu 21.04, it might produce issues with the Kernel DKMS module.

The Pros of the AMDGPU PRO
They’re perfect for professional use, and it offers the OPEN-CL function required by Davinci Resolve, just as @SBHX mentions above. It’s also a nice drive to have, and it’s quite stable.

The Cons of the AMDGPU PRO
As I mentioned above, they can be quite picky with the Kernel version. Some games may produce some horrific frame rates, making you feel your computer belongs in the '90s.

The… Other Option
It all depends on what you need to work on. If it’s fast performance and you enjoy playing games at the best speed possible, then you might want to go with the MESA Open Source drivers. Those are bleeding-edge and may tire you with their literally daily updates! They also fully support up to Ubuntu 21.10 - which is close to release - if it hasn’t already.

If you consider gaming more, including Proton, I’d recommend MESA. If you’re thinking about professional applications, especially Davinci Resolve, then the AMDGPU PRO can serve you better. However, the DKMS might give you a headache. I know I got quite a few… “strokes” from it. :joy:

Please, let me know which direction you want me to take you!

Hmm… @Thorson you might be in luck. It appears that Ubuntu 20.04.3 and Ubuntu 21.04 are running now the same version of Kernel. So, you might want to try the AMDGPU PRO version for 20.04.3.

You will find that here - as well as the Vulkan drivers:


Sorry for delayed reaction here - I’ve updated kernel on my machine to try and see if the NEWEST one would fair better (it didn’t, and I caused my boot manager to default pick the new kernel, crashing EVERY TIME…). I had backed up my system with TimeShift, which was fine for all other issues I’ve created, but did nothing for kernel problems I started having, as the new “broken” one never actually left my system. I tried various tuts to uninstall / remove the new kernel - no luck. I eventually came to a point where the explitives would come in, so, before I started down the path of a “sailor mouth” (no offence meant to all of our Patriot sailors out there :slight_smile: ), I reinstalled Kubuntu. BUUUUT, there is another issue now, as Kubuntu switched to v21.10 (aligned with the newest Ubuntu), and now I have kernel 5.13 something something running on my machine.

Anyway, I attempted to convert .mp4 files into .mov files, which, from what I’m reading, Davinci Resolve prefers (free version, that is), as other file formats are proprietary, and are not included in free DR due to licensing fees and whatnot. None of that works. Maybe it’s due to my AMD Radeon RX 6700 XT driver not being AMD PRO driver, or may be something completely different - not sure. I know that games work, which is less important than video editing, but at least I know that they do, but, while DR sees my GPU properly in settings, and the GPU is set manually, when the .mov file is dropped in and placed in the timeline, it shows up, but does not play at all.

If I need to switch to PRO driver, I may need instructions on how to do that / and how to downgrade my kernel to accommodate.

Any thoughts / suggestions are appreciated (from anyone :smiley: )

Thanks in advance,
Thorson out (temporarily…)

Well, I ran through install instructions for AMDGPU PRO… (again, using kernel v5.13.0-20-generic).

Got the following:

Error! Bad return status for module build on kernel: 5.13.0-20-generic (x86_64)
Consult /var/lib/dkms/amdgpu/ for more information.
dpkg: error processing package amdgpu-dkms (–configure):
installed amdgpu-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of amdgpu:
amdgpu depends on amdgpu-dkms (= 1:; however:
Package amdgpu-dkms is not configured yet.

dpkg: error processing package amdgpu (–configure):
dependency problems - leaving unconfigured
Setting up libegl1-amdgpu-mesa-drivers:i386 (1:21.2.0-1290604) …
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up g++ (4:11.2.0-1ubuntu1) …
update-alternatives: using /usr/bin/g++ to provide /usr/bin/c++ (c++) in auto mode
Setting up build-essential (12.9ubuntu2) …
Setting up amdgpu-lib32 (21.30-1290604) …
Processing triggers for libc-bin (2.34-0ubuntu3) …
Processing triggers for man-db (2.9.4-2) …
Processing triggers for install-info (6.7.0.dfsg.2-6) …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Guess i will need to downgrade my kernel to the supported, whichever that is. But I would appreciate any help with that process!


Hello there Tovarisch!
Ah, the AMD and the professional world! If there’s one thing I did learn during my time in Linux is that AMD cards work great with their open source drivers and games, while when it comes to the professional applications, Nvidia cards tend to work better. No matter, the AMDs can also function, but the company itself is quite slow with their Kernel module applications. However, you are quite right. When I was working with the RX480 (8GB) AMD, I did have my “Greek Sailor” time as well! :laughing:

First things first. If Davinci Resolve works with your current drivers (not the AMDGPU Pro), then you don’t need to switch. Being unable to load certain types of videos on the video editor has nothing to do with the drivers. It’s clearly a matter of codec rights, which other Operating Systems have already purchased/leased. So, if you ever get the Studio version of Davinci Resolve, BlackMagic Design pays a portion of that purchase for the codec rights, so those videos work normally (such as mp4, mkv, h264 etc.).

There are two types of video codecs that will work in Davinci Resolve. One of them is an AVI - which I don’t remember off the top of my head (you can open its settings and check for the “Optimized Media” format - it’s the same), and Apple Prores (Quicktime). The only downside of those codecs is that they can make your video files huge. So, feel free to experiment around.

Now, the way to experiment is via FFMPEG. That little application has been a lifesaver and it basically supports and converts every single codec out there. Unless there are some super proprietary I’m unaware of.

So, go ahead and install FFMPEG first:

sudo apt install ffmpeg

From there, I personally prefer Prores - as it’s the most famous codec for being as close to lossless as possible (no visual artifacts). And FFMPEG does an excellent job of converting to it. Also, depending on the horsepower of your system, it can be pretty fast. It’s actually the fastest converter out there by far. However, it’s command line.

Below you will find an excellent guide per the various formats of the Prores codec and how you can use FFMPEG to convert to them.

Although I’ve tried using ffmpeg to convert to .mov file type, I’ve not yet had any success (I was able to add the file to timeline, and… that’s it, really - they will not show up in the player screen, nor can they be edited in timeline (i.e. cut, add transitions, etc.).

I’ve run through conversion via the link you provided, and I did get an MOV file output (which went from .mp4 file of 91 MB to MOV file of 4.2 GB). I was still not able to edit or do anything with the file in DR other than add it to Media and drag it to Timeline.

I’m not having a warm-and-fuzzy feeling about my prospects here… and it makes me sob a little (on the inside).

Incidentally, here is the neofetch output of my system (for the reference):

OS: Kubuntu 21.10 x86_64
Kernel: 5.13.0-20-generic
Uptime: 3 hours, 45 mins
Packages: 2639 (dpkg)
Shell: bash 5.1.8
Resolution: 1920x1080
DE: Plasma 5.23.1
WM: KWin
WM Theme: Breeze
Theme: Sweet [Plasma], Breeze [GTK2/3]
Icons: Breeze KDE-Story-Dark [Plasma],
Breeze KDE-Story-Dark [GTK2/3]
Terminal: konsole
CPU: AMD Ryzen 9 5900X (24) @ 4.200GHz
GPU: AMD ATI Radeon RX 6700/6700 XT / 6800M
Memory: 6915MiB / 32010MiB

oh, and also wanted to say DA, Comrade :rofl:

I hear you there, Comrade.
Editing a 4.2GB file needs a dedicated SSD - or you could instruct DR to create optimized media from it. The size will be slightly smaller - I believe, but if you do that and on the menu you select to use Proxies, it will be much faster to edit.

I would do all that, except for the fact that I can’t see the video to edit - it’s just added to the Timeline, but not showing up and not playing…

I know I’m doing something wrong, but don’t yet know what.


Okay, then you can use my old traditional method which will load the file and display it on your timeline. Go to your video folder and open a terminal.

ffmpeg -i source_video.mp4 -acodec aac -vcodec prores -f mov

Just remember to replace source_video.mp4 with your mp4 filename and the should be how you want it to be named.

I just ran a test on a 4k video I transcoded on my Ubuntu right now and it works.

I was able to transcode MP4 into MOV, but it still doesn’t work within DR…

Thank you for helping, Vasileios! I keep trying every shred of possible solution, but so far - nada.

I can try installing a different distro / version, maybe?..

I’m running Kubunty 21.10, but I can drop that down to Kubuntu 20.04, maybe, and try again in that. At least I am pretty sure DR works in that version (I hope).

It works good with the AMDGPU Pro, due to its OpenCL support. And DR needs that - obviously. :slight_smile: