Adventures in Pi

I got a Pi4 8gb to play with and a couple extra microSD cards to try some other distros.

The Raspbian OS that comes with it is interesting but underwhelming at 32 bit.
I had no trouble using Etcher on my work laptop (Windoze) to create an Ubuntu SD card which worked no problem. Then, using the same process made one for Manjaro, which would not work. Then tried several more times using different ISO files, different computer (Mint on a 2007 iMac) and none worked. Finally tried the Raspberry bootloader installed on the Ubuntu distro. It has has distro downloads built into it that worked.

Manjaro is lighter weight and peppy but quirky and not as user friendly. I like Ubuntu the best so far.


Love it, just getting my first RP4 driven around the block last few weeks, and I kind of like the simple Rasbian 32bit feel, brings me back to the old MS OS’s from decades ago now. Using it mostly from terminal commands to learn that side of things. After some researching, I realized that the processor is in fact 64 bit on all RP4’s, so I’m happy to try Ubuntu and Kali on my others that are incoming. (I’m hopelessly addicted after getting just one!) And ordered some extra SD cards to quickly swap out builds.

In case anyone hasn’t checked, RP4’s are getting difficult to find, and limit of 1 per customer per day, or ‘ships in Feb’ notices everywhere, get them while you can! At least get the boards and tuck them away for a rainy day, or a new project without interrupting whatever you have going on at any moment.


It is so cool to be able to install different distros on individual SD cards and just swap them out at will.

Yes, they are getting hard to find. When I ordered mine a couple weeks ago, all the stores linked from the official site were out of stock on the 8GB model kits. All the sellers on eBay are price gouging. I ended up getting a good deal on one through Best Buy.