802.11 AC wireless card or dongle

Anyone using a 802.11 AC dongle or added on a wireless card to their laptop for AC?

Hey, @wadesmart!
I have one card for my stepson’s desktop, but I have him on Windows - unfortunately. He’s a Roblox and Fortnight addict, so if I install Linux on his system, I’ll be in a heap of trouble!
Something tells me you have an issue configuring it (or having it recognized by Linux)?

Can you post the output of the following terminal command?


This will show if Linux can identify the hardware.

Im running a Edimax EW7811 AC600 UTC and requires the rtl8812au drivers. The drivers that were out worked up to 4.15.0 to 5.11 kernel version … but they do not work with 5.4. I was sent a link to a aircrack-ng on github for updated drivers. Im going to look into those today when I have time.

Sounds like a plan then. Worst case scenario, you can upgrade your Kernel and see if that helps. :slight_smile:

Im using KDE neon 5.22.4 on my working laptop right now … the instructions that were sent to me …

Here was the page…

I went to the git link…where the supported os’s … dont include mine. Reading thru I find that some are still not able to get this to work. I may just look for another ac option

Those are some good instructions, with - perhaps - on minor item missing. Some systems do not come with DKMS (kernel module installer). You can retry the process in the link, but first open up a terminal (named “Konsole” in KDE), and type in:

sudo apt install dams

If it’s installed, then you go on ahead and try the instructions in the link. :slight_smile:

Ive tried the instructions on the open source page since my kernel is newer than what is supported.

Im going to look for other drivers that will work on newer kernels.

I ran a update yesterday for a piece of software I installed but I just ran another update to install something else after installing the ppa and then installing I glanced down and I noticed my wireless dongle was lit up. I checked and sure enough - 5Ghz is connected. Its only at 64Mbps download and 20Mbps up but… that is still far better than before.

1 Like

That’s great! At least things started working. The download and upload bandwidth could be a limitation from the router - especially if it has speed allocation (for many devices). What’s your line speed?

My newer Thinkpad with AC built in is moving about 110 down but 20 up is the same as my connection is 200/20 at 4 latency. I have a linksys ac1900 with ddwrt v3.0r44715.

It could be this dongle as even on the windows unit my wife has - it runs similar speed.

That sounds like it then. At least it’s working!

Well - not working as well as I would like.

My router: linksys wrt1900acs v2 running ddwrt.
My wireless ext: TP-Link AC2600 (RE650).

Both are about 15 ft in either direct -/+ 2ft.

To my router: 5Ghz, 36 ping, 40 down and 19 up.
To my router: 5Ghz (different placement, going higher), 35 ping, 46 down, 20 up
To my router: 2.4 Ghz, 35 ping, 24 down and 20 up.

To my tplink ext: 5Ghz, 40 ping, 15 down and 20 up.
To my tplink ext: 2.4Ghz, 39 ping, 31 down and 18 up

What sucks is - on Windows 7 before I wiped it - I was running
14 ping, 71 down 21 up.

My package here is 200/20 and I average 3-5ms ping on my desktop.
We are coax here. Ive read about tweaking ddwrt wireless settings but
it seems its all in the dongle for now.

$ iwconfig
5.745 freq, 87MB/s bit rate, hitting the router, link quality is 36/100, -33dBm, 0 noise, power management off.

$ nmcli dev wifi
router: channel 149, 260 Mbit, signal 100, wpa2 security
ext: channel 149, 195 Mbit, signal 100, wpa2 security

I installed the rtl8812au but I was talking on chat with someone and they
were referencing a reddit forum - which I do not have access to yet - where it was suggested to use rtl88x2bu. Question: you cant just switch from the 8812 to the 88x2 as the first driver is for that version of hardware - right?

It could be a power on your WiFi issue. I’ve had it happen to me before, but not all adapters allow increasing power. In some cases, the low power was due to a not so great firmware that I had to replace to a previous version.

Per the driver, when you first install Linux, you will get the default, yes, but nothing is stopping you from switching to the 88x2, as the “x” is supposed to stand for the entire model range.

Ok. First, there was a page I read about power management - so Ill see about turning that up a bit and after testing, I might try that other driver. Ill post back after that. Thanks.

1 Like