SSH error message

I was trying to harden my server following the steps outlined from Jay on the Linode Youtube channel. I followed his instructions to update the server and rebooted. After the reboot, I get an "Access Denied (PublicKey) error message when I try to SSH into the server from the Terminal. How do I go about fixing this? Trying to find instructions online and I am more confused than ever. Thanks.

Ok, have you asked Jay? I am not trying to be quip or cute, I am saying what did Jay have you doing? Unless you have a copy of your terminal session (please attach if so) and posted it here, how would anyone here KNOW what you have done, and therefore how to help fix or undo?

Do you see what I’m saying? Any help there?

@gburke are you registered for the jeff.pro classes? If so, there is a geat lesson on hardening your server to be seen. @vasileios is definitely the guy to ask. If you are still having issues he will help.

Hey @gburke and welcome to the forums!
Thank you for tagging me, @BigDaveAZ! I’ve been on an all-but-impossible deadline this past month, up until June 5th, hence my less frequent visits (I come here during my breaks, when I’m not eating or using the bathroom :laughing: ).

@gburke -
I don’t know what changes you may have done to the SSH, so a recap would be useful. From the message you are showing, I am thinking that you are trying to login as root. All hardening paths include disabling the root login process, so you’ll need to have a non-root user to login with. However, that user will need to copy the same SSH key up to the server (which is the same key you used for the root).

In order to do that, you will need to temporarily allow a password login via the SSH configuration. The only way you can do that is if you go to your Linode account, select your server and then hit the LISH option on the top right. Select the GLISH and login as root to make the changes.

Remember to roll the changes back (disable password logins) once done. And restart the sshd once you want to implement the changes.