Setting up Wireguard on Linode

Hey @Jenny8675309 - That Debian option should work just fine. Linux Mint is based on the Debian distro, so it should be a 1 for 1 translation.

1 Like

Thank you! I’ve set up the VPS with Wireguard using a Git Hub script. I got a QR code and I’ve set up my phone using the Wireguard app!

I’m trying to figure out how to use Wireguard from my desktop. I’ve installed Wireguard through the terminal and ran a script for a Wireguard GUI, but I can’t seem to find the GUI application. I’ve downloaded my conf file using FileZilla. From what I understand, I need to import the conf file into Wireguard GUI application to get it running.

1 Like

@Ai I finally got my desktop VPN running!

I copied the *.conf file from my VPS using FileZilla.

I opened “Advanced Network Configuration” on my desktop and hit the “+” sign to add a new connection. Under “Choose a Connection Type” I selected “Import a saved VPN configuration file.” I chose “Create” and I chose my VPS *.conf file to import. After Import, hit Save.

Then I went back to the Network application and turned on my new connection. I verified my connection by going to

I appreciate all the help and encouragement!


Wow, @Jenny8675309, thank you for sharing this happy news, perfect timing, I needed it!
:grinning: :tada:

1 Like

Hi Jenny, I am on a Wireguard VPN journey right now as well. Can you post a link to the Git Hub script that you used?

Sure! It worked really well for me!


Jenny, can you explain to me exactly what you did, “step by step,” to use the Git Hub script? It says:
Run the script and follow the assistant:
wget -O && bash
So does that mean you just copy and paste this code and then an assistant will come up? Or do you have to click on the file, and copy and paste that? Sorry for such baby questions.

Hey LibertyMom!

Looking at my notes, I logged into the server by typing SSH root@ with your VPS IP # and then pasted that whole line starting with “wget” into the terminal. It ran pretty quickly and it asked a few questions. For the DNS question, I picked

At the end, it will give you a QR code. You can download the Wireguard app on your phone and use the QR code to install the VPN on your phone.

I hope that helps!


Basically the && symbols line up consequent commands. The first “wget” downloads a specific file from the GitHub repository named “” and the “bash” command afterwards executes it directly. :slight_smile:

1 Like

Hi Jenny, yes, that is very helpful. I will let you know if I get mine running soon! Say a prayer lol.

1 Like

Thank you Vasileios for that explanation, which helps me understand what the heck I am doing. :sweat_smile:

1 Like

You are most welcome @LibertyMom! Through all the steps, it would seem the internet can still be an issue when connecting to the VPN. Of course, I tried it with a CentOS server, so its firewall/security could have gotten in the way.
How is your effort proceeding?

@vasileios I am having trouble connecting to my linode with filezilla. I am running Ubuntu if that helps. Everything seems fine. It will ask about the fingerprint and then runs a few lines then tells me Error: Authentication failed. Error: Critical error: Could not connect to server. Any ideas what might be the problem? I followed the instructions given on Linode’s forum to connect via SFTP using FileZilla. I am wanting to use it to move the *.conf file to my laptop to connect to my VPN serer like @Jenny8675309 did. It is working great on my phone as I loaded the files with the QR code it sent me.

Hey @Shane!
Did you follow this specific guide?

There might be a few tricks to this trade, but in worst case scenario, you can use the SCP (Secure Copy) command, as long as you have its exact address on the server.

Let’s say you still have the root user, that command will be:

scp root@X.X.X.X:/folder1/folder2/*.conf /home/your_home_username/Downloads

Where X.X.X.X is your server’s IP address, folder1,2 etc. is the folders where your conf file is in; and your_home_username is where your actual username is (under your laptop’s /home folder).

Since the file you download is probably permissions only for the root user, you might want to:

cd ~/Downloads
sudo chown your_username *.conf

Where “your_username” is your actual username and the “*.conf”" is the name of your configuration file. Once that is done, you’ll be good to go!

1 Like

Hello @vasileios! I still did not get FileZilla to work. I will try the SCP. It will give me more practice in using the command line. :smiley:

I do have another question about VPS running a VPN. So a VPS says it has a bandwidth of 512MB or 1GB. Would running a VPN on this hit this bandwidth limit rather quickly. I view a lot of video. This would cause me to hit this bandwidth limit very fast wouldn’t it, or is there something I am missing or not understanding?

If your VPS provider only gives your server 1GB, then yes, you will run out rather quickly. However, if you’re on Linode, I think they give 1TB bandwidth and their smallest server has 1GB of RAM - which is different. :wink:

@vasileios I have been successful at setting up a wireguard VPN on a linode server with the wire script posted here and it is super easy to get a mobile device set up by scanning the QR code.

But I have not successfully installed on a computer.

I was successful at transferring the Desktop.config file with the commands you provided.

Then I ran the command

sudo nano /etc/wireguard/Desktop.config

Pasted the contents from the transfered Desktop.config file and saved

Then ran command

wg-quick up Desktop

this is the output

#] ip link add Desktop type wireguard
[#] wg setconf Desktop /dev/fd/63
[#] ip -4 address add dev Desktop
[#] ip -6 address add fddd:2c4:2c4:2c4::3/64 dev Desktop
[#] ip link set mtu 1420 up dev Desktop
[#] resolvconf -a Desktop -m 0 -x
/usr/bin/wg-quick: line 32: resolvconf: command not found
[#] ip link delete dev Desktop

Do you know might be happening?

I have been fiddling around trying to find what is wrong. I opened /usr/bin/wg-quick and this what line 32 contains: echo “[#] $*” >&2

Makes no sense to me.

Hey @Shane!
I’ve encountered a lot of issues with the manual installation of WireGuard, therefore I decided to let that one go and go via OpenVPN, which is more direct and reliable (WireGuard is still in development and may have significant security issues on Ubuntu - or at least that was the warning I got).

However, if you insist on WireGuard, you can reset the server and use the script below. :slight_smile:

Also, seems to me you’re missing a command:

sudo apt install resolvconf

That’s the error you’ve been getting. :wink: