Bluetooth keeps quitting on all linux distros

I use Bluetooth for a while then suddenly it disappears. Now I am using OpenSUSE 15.3.

Hello @Defendur and welcome to the forums!

OpenSUSE is quite the complicated distro - especially since it’s targeted for developers. :wink:

Yes, sometimes the Bluetooth can give quite a bit of trouble. Have you tried switching the Bluetooth manager? Unfortunately it has been ages since I laid hands on OpenSUSE (and its Zypper packet manager).

I will try that, Thank You. I really like the speed, it is like lightning. Also at some point, I would like to try containers.

Are you saying you have something (headphones) attached and then the connection drops?

https://opensuse.github.io/openSUSE-docs-revamped-temp/bluetooth/

1 Like

No, I come back to the computer after shutting it down for the night and no bluetooth icon. I check the settings and it says there is no bluetooth adapter. This has happened to me on various distros. I am wondering if it is the kernel?

Might be the kernel, but if you’re having this issue across different distros, that makes me think that it might be a hardware issue. Have you tried researching any necessary drivers for your computer?

1 Like

I am not sure how to do anything with linux hardware drivers. When I do updates, or upgrades, that is when I lose the Bluetooth.

All Linux drivers are handled in the following two ways:

  1. As internal or external modules on the Linux Kernel,
  2. As firmware files, combined with Kernel module drivers.

Since your Bluetooth works normally when you first install your system, it means that the upgrade is updating the firmware files. That’s what is causing the issues. A workaround I found for it is to copy the original firmware files, and then copy them back after an upgrade.

Can you post the output of the following command?

lspci

From there we can see which model your Bluetooth is and try to spot the respective firmware files in the library.